helpf.pro
Регистрация

?:

novichok20
24.01.2016 02:45Прочитано: 1392

Всем привет. ни разу ни сталкивался с временным хранилищем.нужна помощь разобраться.

есть общая форма с таблицей значений.

в этой таблице при выборе значения,я открываю форму документа.

так вот мне необходима передать значение из таблицы в реквизит документа который я открываю.

подскажите пожалуйста как это все реализовать.заранее благодарен.

Код 1C v 8.2 УП
 &НаКлиенте
Процедура ЗаявкиПоставщикОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
     
Если ВыбранноеЗначение = ОткрытьФормуЗаказ()  
Тогда
ВыделенныеСтроки=Элементы.Заявки.ТекущиеДанные;
п=Элементы.Заявки.ТекущиеДанные.Описание;


Док=ПолучитьФорму("Документ.РасходБумаги.Форма.ФормаДокумента");

Док.Открыть();

КонецЕсли;

КонецПроцедуры




&НаСервере


Функция ОткрытьФормуЗаказ()

Код="СКЛАД";
    М= Справочники.Поставщики.НайтиПоКоду(Код);
Возврат м;  

КонецФункции


Yandex
Возможно, вас также заинтересует
Реклама на портале
novichok20
25.01.2016 13:22Ответ № 1
Вопрос закрыт!
E_Migachev
25.01.2016 17:42Ответ № 2

Зачем тебе таблица значений, ее нельзя передать на сервер, используй структуру или через параметр

Подсказка: Щелникни по Имени пользователя напротив ответа, и тем самым покажешь, что сообщение адресовано ему.
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.