helpf.pro
Регистрация

v8.3: табличный документ на форме- Недопустимая операция для реквизита формы

tvm
16.05.2016 15:47Прочитано: 6826

отчет на УФ. На форме есть реквизит ТабДок- табличный документ. При команде "Показать" выдает ошибку "

{Форма.ФормаОтчета.Форма(266)}: Ошибка при вызове метода контекста (Показать) ТабДок.показать();по причине:Недопустимая операция для реквизита формы"

Код 1C v 8.3
 &НаСервере
процедура СформироватьНаСервере()
    текОбъект = РеквизитФормыВЗначение("Отчет");
    Макет = текОбъект.ПолучитьМакет("Макет1");
ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
    ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
    ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
    ОбластьПодвалТаблицы = Макет.ПолучитьОбласть("ПодвалТаблицы");
    ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");
    // тут выполняется запрос
    ТабДок.Очистить();
    ТабДок.Вывести(ОбластьЗаголовок);
    ТабДок.Вывести(ОбластьШапкаТаблицы);
    ТабДок.НачатьАвтогруппировкуСтрок();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетальныеЗаписи);
        ТабДок.Вывести(ОбластьДетальныхЗаписей, ВыборкаДетальныеЗаписи.Уровень());
    КонецЦикла;
    
    ТабДок.ЗакончитьАвтогруппировкуСтрок();
    ТабДок.Вывести(ОбластьПодвалТаблицы);
    ТабДок.Вывести(ОбластьПодвал);
    
    //}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
    
    ТабДок.ОтображатьСетку = Ложь;
    ТабДок.ТолькоПросмотр = Истина;
КонецПроцедуры

&НаКлиенте
Процедура Сформировать(Команда)
СформироватьНаСервере();
ТабДок.показать();
КонецПроцедуры
Yandex
Возможно, вас также заинтересует
Реклама на портале
safin
17.05.2016 13:21Ответ № 1
all4cf
19.05.2016 17:47Ответ № 2

а что ты показываешь?

тогда делай СформироватьНаСервере как функцию, в конце возврат табдок; 

а в сформировать:

Код 1C v 8.3
 &НаКлиенте
Процедура Сформировать(Команда)
  ТабДок = СформироватьНаСервере();
   ТабДок.показать();
КонецПроцедуры   
Подсказка: Щелникни по Имени пользователя напротив ответа, и тем самым покажешь, что сообщение адресовано ему.
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.