helpf.pro
Регистрация

v8.2 УП: создание документов по датам из табличной части

PahaB
25.05.2016 18:06Прочитано: 893

Здравствуйте, через запрос заполняю табличную часть обработки, в этой табличной части можно поменять значение колонки дата. Подскажите пожалуйста как реализовать следующее: По дате будет формироваться документ "заказ покупателя".Все строки с одинаковой датой в один документ, с дургой во второй и так далее.

Yandex
Возможно, вас также заинтересует
Реклама на портале
PahaB
26.05.2016 14:34Ответ № 1

Решил! может кому пригодится. Есть конечно что доработать, но принцип я надеюсь понятен.

Код 1C v 8.2 УП
 Процедура КнопкаВыполнитьНажатие (Кнопка)
    //временная таблица
    КопияОтобранныеДаные     = Новый ТаблицаЗначений;
    //таблица для загрузки в документ
    ТаблицаЗагрузки         = Новый ТаблицаЗначений;
    
    КопияОтобранныеДаные     = ОтобранныеДанные.Выгрузить();
    ТаблицаЗагрузки            = ОтобранныеДанные.Выгрузить();
    ТаблицаЗагрузки.Очистить();

    Для Каждого СтрокаОД ИЗ ОтобранныеДанные Цикл
        
        К = 0;
        
        Пока КопияОтобранныеДаные.Количество() <> К Цикл            
            
            Если СтрокаОД.НазначитьВыдачу = КопияОтобранныеДаные[К].НазначитьВыдачу Тогда
        
                СтрокаТаблицыЗагрузки = ТаблицаЗагрузки.Добавить();
                ЗаполнитьЗначенияСвойств(СтрокаТаблицыЗагрузки, КопияОтобранныеДаные[К]);
                        
                КопияОтобранныеДаные.Удалить(К);
            Иначе
                К = К + 1;     
            КонецЕсли;
            
         КонецЦикла;
        
        Заказ = Документы.ВнутреннийЗаказ.СоздатьДокумент();
    КонецЦикла
    КонецПроцедуры
PahaB
26.05.2016 14:34Ответ № 2
Вопрос закрыт!
Подсказка:Вы можете добавить любую страничку в Социальные закладки щелкнув по значку соцсетей (в вверху)
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.