helpf.pro
Регистрация

v8.2 УП: Здравствуйте, помогите решить вот такую проблему: в справочнике Номенклатура

modoll
13.06.2016 13:08Прочитано: 2724

Здравствуйте, помогите решить вот такую проблему: в справочнике "Номенклатура" необходимо заполнить реквизит Бренд (он уже создан) из обработки. Данные в обработку добавляются из Excel.

Заранее спасибо!

Yandex
Возможно, вас также заинтересует
Реклама на портале
modoll
13.06.2016 13:28Ответ № 1

Вот текст программы:

Процедура ЗагрузитьБрэнд()

Для Каждого Элемент Из Товары Цикл

СпрНом = Справочники.Номенклатура;

Условие = НоменклатураПоКоду(СокрЛП(Элемент.Штрихкод));

//НоменлСсылка = НоменклатураПоКоду(СокрЛП(Элемент.Штрихкод));

Если(Условие = Неопределено) Тогда

Сообщить("Не найдена номенклатура с кодом: " + Элемент.Штрихкод,СтатусСообщения.ОченьВажное);

Иначе

НоменлОбъект = Условие.ПолучитьОбъект();

НоменлОбъект.Брэнд = Товары.Брэнд;

Попытка

НоменлОбъект.Записать();

Исключение

Сообщить(ОписаниеОшибки());

КонецПопытки;

КонецЕсли;

КонецЦикла;

Попытка

Обработка = Обработки.РегламентныеЗагрузкаНоменклатуры.Создать();

Обработка.ОчиститьУзлыНоменклатуры();

Исключение

КонецПопытки;

Предупреждение("Загружено");

Конецпроцедуры

modoll
13.06.2016 13:29Ответ № 2

Процедура ЗагрузитьБрэнд()

Для Каждого Элемент Из Товары Цикл

СпрНом = Справочники.Номенклатура;

Условие = НоменклатураПоКоду(СокрЛП(Элемент.Штрихкод));

//НоменлСсылка = НоменклатураПоКоду(СокрЛП(Элемент.Штрихкод));

Если(Условие = Неопределено) Тогда

Сообщить("Не найдена номенклатура с кодом: " + Элемент.Штрихкод,СтатусСообщения.ОченьВажное);

Иначе

НоменлОбъект = Условие.ПолучитьОбъект();

НоменлОбъект.Брэнд = Товары.Брэнд;

Попытка

НоменлОбъект.Записать();

Исключение

Сообщить(ОписаниеОшибки());

КонецПопытки;

КонецЕсли;

КонецЦикла;

Попытка

Обработка = Обработки.РегламентныеЗагрузкаНоменклатуры.Создать();

Обработка.ОчиститьУзлыНоменклатуры();

Исключение

КонецПопытки;

Предупреждение("Загружено");

Код 1C v 8.2 УП
 Конецпроцедуры   
modoll
13.06.2016 13:29Ответ № 3
Код 1C v 8.2 УП
 
Процедура ЗагрузитьБрэнд()

Для Каждого Элемент Из Товары Цикл
СпрНом = Справочники.Номенклатура;
        Условие = НоменклатураПоКоду(СокрЛП(Элемент.Штрихкод));
        //НоменлСсылка = НоменклатураПоКоду(СокрЛП(Элемент.Штрихкод));

Если(Условие = Неопределено) Тогда 
Сообщить("Не найдена номенклатура с кодом: " + Элемент.Штрихкод,СтатусСообщения.ОченьВажное);
Иначе



НоменлОбъект = Условие.ПолучитьОбъект();

НоменлОбъект.Брэнд = Товары.Брэнд;
Попытка
НоменлОбъект.Записать();
Исключение
   Сообщить(ОписаниеОшибки());
КонецПопытки;
КонецЕсли;
КонецЦикла;

Попытка
Обработка = Обработки.РегламентныеЗагрузкаНоменклатуры.Создать();
   Обработка.ОчиститьУзлыНоменклатуры();
Исключение
КонецПопытки;

Предупреждение("Загружено"); 

Конецпроцедуры


Подсказка: Щелкнув по значку (справа от названия вопроса), вы получите список ответов на похожие вопросы!
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.