helpf.pro
Регистрация

v8.2 УП: заполнение таблиц документов из массива строк по условию

PahaB
18.06.2016 08:45Прочитано: 2278

Помогите пожалуйста с заполнением таблиц документов из массива Massiv.doc(из массива берется Номенклатура, Хар-ка номенклатуры, Единицы измерения, Статья затрат, Плановое кол-во и Коли-во к получению) или из этих данных получить таблицу, дальше справлюсь. Пока придумал только такое. Заранее спасибо! 

Код 1C v 8.2 УП
 
ТаблицаБП = Новый ТаблицаЗначений;

ТаблицаБП.Колонки.Добавить("Номенклатура");
ТаблицаБП.Колонки.Добавить("ХарактеристикаНоменклатуры");
ТаблицаБП.Колонки.Добавить("ЕдиницаИзмерения");
ТаблицаБП.Колонки.Добавить("СтатьяЗатрат");
ТаблицаБП.Колонки.Добавить("ПлановоеКоличество");
ТаблицаБП.Колонки.Добавить("КоличествоКПолучению");

//Инт_Вход_НачалоСессии.РеквизитыЗначения-массив
Для Каждого СтрокаБП из Инт_Вход_НачалоСессии.РеквизитыЗначения Цикл

Если СтрокаБП.СтрокаНомер > 0 Тогда

СтрокаНомер = СтрокаБП.СтрокаНомер;
//получаем реквизиты и значения строки
Отбор = Новый Структура;
Отбор.Вставить("СтрокаНомер", СтрокаНомер);
Строки = Инт_Вход_НачалоСессии.РеквизитыЗначения.НайтиСтроки(Отбор);
     
КонецЕсли;

КонецЦикла
Yandex
Возможно, вас также заинтересует
Реклама на портале
all4cf
19.06.2016 18:41Ответ № 1

Не совсем понятно что нужно!? Если правильно понял, то есть таблица с данными, перебирай ее и заполняй новый документ 

PahaB
19.06.2016 19:13Ответ № 2

просто думал может как-то быстро можно по реквизиту заполнить таблицу значениями, а в результате получается так?!

Код 1C v 8.2 УП
 	Для Каждого СтрокаБП из Инт_Вход_НачалоСессии.РеквизитыЗначения Цикл

Если СтрокаБП.СтрокаНомер > 0 Тогда

СтрокаНомер = СтрокаБП.СтрокаНомер;
//получаем реквизиты и значения строки
Отбор = Новый Структура;
Отбор.Вставить("СтрокаНомер", СтрокаНомер);
Строки = Инт_Вход_НачалоСессии.РеквизитыЗначения.НайтиСтроки(Отбор);
     
Для Каждого ст из Строки цикл

Если ст.Реквизит = Номенклатура Тогда
ТаблицаБП.Номенклатура = СтрокаБП.Значение
ИначеЕсли Ст.Реквизит = Характеристика номенклатуры Тогда
ТаблицаБП.ХарактеристикаНоменклатуры = СтрокаБП.Значение
ИначеЕсли Ст.Реквизит = Единица измерения Тогда
ТаблицаБП.ЕдиницаИзмерения= СтрокаБП.Значение ИначеЕсли Ст.Реквизит = Статья затрат Тогда
ТаблицаБП.СтатьяЗатрат = СтрокаБП.Значение
ИначеЕсли Ст.Реквизит = Плановое Количество Тогда
ТаблицаБП.ПлановоеКоличество = СтрокаБП.Значение
ИначеЕсли Ст.Реквизит = Количество к получению Тогда
ТаблицаБП.Количество к получению = СтрокаБП.Значение
КонецЕсли


КонецЦикла
КонецЕсли;

КонецЦикла
Подсказка: Для редактирования своего ответа щелкните по значку (справа)
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.