helpf.pro
Регистрация

v8: Свормировать структура ХМЛ файла

Bell
20.06.2016 12:54Прочитано: 1503

Здравствуйте

Имею Таблицу значений: ТаблицаДокументов. 

Колонки:  Док(тип.Строка) и Контрагент

Данные таблицы значений

Док1Контрагент1

Док1Контрагент1

Док2Контрагент2

Док2Контрагент2

/// =============================

Требуется создать структура Узлы равны по подчиненности. Не могу убрать ПОВТОРЕНИЯ, если документ повторяется несколько раз в таблице значений

//// ===========================

УзелДок1 /// Начало узла Док1

УзелКонртагент1 /// Начало узла Контрагент1

УзелКонртагент1 /// Конец узла Контрагент1

УзелДок1 /// Конец узла Док1

УзелДок2 /// Начало узла Док2

УзелКонртагент2 /// Начало узла Контрагент2

УзелКонртагент2 /// Конец узла Контрагент2

УзелДок2 /// Конец узла Док2

/// ==========================================

Для каждого СтрокаОдин Из ТаблицаДокументов Цикл

Для каждого СтрокаДва Из ТаблицаДокументов

;Если Строка(СтрокаОдин.ДокументСсылка) <> Строка(СтрокаДва.ДокументСсылка) Тогда

Иначе

КонецЕсли;

КонецЦикла;

КонецЦикла;

Yandex
Возможно, вас также заинтересует
Реклама на портале
all4cf
20.06.2016 17:20Ответ № 1

так откажись от таблицы значений, сделай запрос и в нем группировку по документу

Bell
21.06.2016 08:37Ответ № 2

Это схема. Я такой запрос не смогу составить. Это перегрузка нескольких документов связанных документов. Мне принцип нужен.

Подсказка: Щелкнув по значку (справа от названия вопроса), вы получите список ответов на похожие вопросы!
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.