helpf.pro
Регистрация

v8: ТТН ЕГАИС в ФС РАР

apostol
26.09.2016 11:23Прочитано: 2343

Доброе утро! 

Подскажите пожалуйста, пишу обработку чтобы из 1с на портал check1.fsrar.ru отправить запрос о статусе ТТН, и чтоб сразу же в форму подставилась информация о моем индификационном номере егаис, и номер Фикcации ТТН в егаис. С толкнулся с проблемой, страница открывается а вот данные не передаются, подскажите пожалуйста, где ошибка, или может чего то не дописал.

Код 1C v 8.х
  ТекущаяСтрока = ЭлементыФормы.ДокументыРеализации.ТекущиеДанные;

Если ТекущаяСтрока = Неопределено Тогда
Предупреждение("Выберите строку с документом продажи", 10);
Возврат;
КонецЕсли;

Если Вопрос("Отправить запрос на сайт проверки?", РежимДиалогаВопрос.ДаНетОтмена) <> КодВозвратаДиалога.Да Тогда
Возврат;
КонецЕсли;

//Для каждого Выборка из ТекущаяСтрока Цикл
IE= Новый COMОбъект("InternetExplorer.Application");
IE.Visible = Истина;
IE.Navigate("https://check1.fsrar.ru");
Пока IE.readyState < 4 Цикл
КонецЦикла;
IE.document.getElementByID("code_wb").value = Прав(ТекущаяСтрока.ИдНомерЕГАИС,10); // code_wb
IE.document.getElementByID("owner_r1").value = FSRARID;
Yandex
Возможно, вас также заинтересует
Реклама на портале
all4cf
26.09.2016 12:15Ответ № 1

это вы установили поля, но надо нажать и кнопку!?

почему бы не попробовать через HTTPСоединение

apostol
26.09.2016 12:41Ответ № 2

А можешь пример набросать через HTTPСоединение. Если не сложно

Подсказка:Вы можете добавить любую страничку в Социальные закладки щелкнув по значку соцсетей (в вверху)
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.