helpf.pro
Регистрация

v8.3: Нечеткий поиск по наименованию в справочнике номенклатура

nnaavv
08.02.2017 15:28Прочитано: 4465

Подскажите каким запросом можно произвести поиск по наименованию в справочнике номенклатура по вхождению нескольких слов из искомого значения.

Например значение поиска "булка хлеба черного"

найти все вхождения из справочника номенклатура где встречаются эти слова.

Yandex
Возможно, вас также заинтересует
Реклама на портале
all4cf
10.02.2017 12:45Ответ № 1

Запросом можно попробовать через ПОДОБНО разделив слова %

но лучше использовать полнотекстовый поиск:

Код 1C v 8.3
 Если ПолнотекстовыйПоиск.ПолучитьРежимПолнотекстовогоПоиска() <> РежимПолнотекстовогоПоиска.Разрешить Тогда
Отказ = Истина;
Сообщение = Новый СообщениеПользователю();
Сообщение.Текст = НСтр("ru = 'Использование полнотекстового поиска не разрешено. Вы можете включить его в диалоге ""Управление полнотекстовым поиском""'", "ru");
Сообщение.Сообщить();
Возврат;
КонецЕсли;

тчРезультата.Очистить();
текдок = Новый ТекстовыйДокумент;
текдок.УстановитьТекст(ТестПоиска);
Для Ном=1 по текдок.КоличествоСтрок() цикл
Стр = СокрЛП(текдок.ПолучитьСтроку(Ном));
СписокПоиска = ПолнотекстовыйПоиск.СоздатьСписок(Стр);
СписокПоиска.ПолучатьОписание = Истина;
СписокПоиска.РазмерПорции = 5;

СписокПоиска.ПорогНечеткости = ПорогНечеткости;

МассивОтбор = Новый Массив();
МассивОтбор.Добавить(Метаданные.Справочники.Контрагенты);
//МассивОтбор.Добавить(Метаданные.Документы.КассовыйЧек);
СписокПоиска.ОбластьПоиска = МассивОтбор;
СписокПоиска.ПерваяЧасть(); // Выдает по 5 результатов - РазмерПорции
// Если нужно листать
// СписокПоиска.ПредыдущаяЧасть(ТекущаяПозиция);      
// СписокПоиска.СледующаяЧасть(ТекущаяПозиция);      

Для каждого Результат Из СписокПоиска Цикл
нСтр=тчРезультата.Добавить();
нСтр.ТекстПоиска=Стр;
нСтр.Контрагент=Результат.Значение;
КонецЦикла;
КонецЦикла;

Вот подробнее: Полнотекстовый Поиск - пример поиска контрагентов в базе

Eugeneer
11.07.2021 11:09Ответ № 2

Сопоставление номенклатуры поставщиков в 1С (нечеткий поиск)

Уникальный функционал - сопоставление номенклатуры поставщиков (нечеткий поиск). Алгоритмы позволяющие управлять в конкретной ситуации сопоставлением.

Полностью управляемый и контролируемый процесс настройки поиска и подбора номенклатуры.

https://subsystems.ru/solutions/megaprays-nomenklatura/sopostavlenie-nomenklatury-postavshchikov-v-1s-nechetkiy-poisk/

Подсказка: Для быстрого перемещения к последнему ответу или к вопросу используйте или .
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.