helpf.pro
Регистрация

v8.3: Помогите доработать код Прикрепление внешних файлов к документам

saha85
05.03.2017 09:24Прочитано: 3592

//*************************************Загрузка Коммерческих Предложений 1********************************

&НаКлиенте

Процедура ВыбратьФайлСДискаИЗаписать()

Перем ВыбранноеИмя;

Перем АдресВременногоХранилища;

НовыйОбъект = Объект.Ссылка.Пустая();

Если ПоместитьФайл(АдресВременногоХранилища, "", ВыбранноеИмя, Истина) Тогда

Объект.ИмяКП1 = ВыбранноеИмя;

ПоместитьФайлОбъекта(АдресВременногоХранилища);

Если НовыйОбъект Тогда

ОтобразитьИзменениеДанных(Объект.Ссылка, ВидИзмененияДанных.Добавление);

КонецЕсли;

КонецЕсли;

КонецПроцедуры

&НаКлиенте

Процедура ПрочитатьФайлИСохранитьНаДиск()

Если Объект.Ссылка.Пустая() Тогда

Предупреждение(НСтр("ru = 'Данные не записаны'", "ru"));

Возврат;

КонецЕсли;

Если ПустаяСтрока(Объект.ИмяКП1) Тогда

Предупреждение(НСтр("ru = 'Имя не задано'", "ru"));

Возврат;

КонецЕсли;

Адрес = ПолучитьНавигационнуюСсылку(Объект.Ссылка, "КПФайл1");

ПолучитьФайл(Адрес, Объект.ИмяКП1, Истина);

КонецПроцедуры

&НаСервере

Процедура ПоместитьФайлОбъекта(АдресВременногоХранилища)

ТекущийДокумент = РеквизитФормыВЗначение("Объект");

ДвоичныеДанные = ПолучитьИзВременногоХранилища(АдресВременногоХранилища);

ТекущийДокумент.КПФайл1 = Новый ХранилищеЗначения(ДвоичныеДанные);

Файл = Новый Файл(ТекущийДокумент.ИмяКП1);

ТекущийДокумент.ИмяКП1 = Файл.Имя;

ТекущийДокумент.Записать();

Модифицированность = Истина;

УдалитьИзВременногоХранилища(АдресВременногоХранилища);

ЗначениеВРеквизитФормы(ТекущийДокумент, "Объект");

КонецПроцедуры

&НаКлиенте

Процедура ЗагрузитьКП1(Команда)

ВыбратьФайлСДискаИЗаписать();

Возврат;

КонецПроцедуры

&НаКлиенте

Процедура ПоказатьКП1(Команда)

ПрочитатьФайлИСохранитьНаДиск();

Возврат;

КонецПроцедуры

//*************************************Конец Загрузка Коммерческих Предложений 1********************************

//*************************************Загрузка Комерческих Предложений 2**************************************

Как сделать загрузку второго КП2

//*************************************Конец Загрузка Коммерческих Предложений 2********************************

Yandex
Возможно, вас также заинтересует
Реклама на портале
saha85
05.03.2017 09:35Ответ № 1

all4cf
06.03.2017 00:12Ответ № 2

а в чем проблема?

Подсказка: Для быстрого перемещения к последнему ответу или к вопросу используйте или .
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.