helpf.pro
Регистрация

v8: Записать СписокЗначений в ХранилищеЗначений

Нерекаемый
02.06.2017 16:32Прочитано: 1943

Пытаюсь сделать внешнюю обработку на добавление складов в узлы обмена, но не понимаю как записать список значений в хранилище значений, что то попробовал но выдает ошибку, куда копать, есть ли какие советы? Заранее спасибо. 

Код 1C v 8.х
 

Процедура КнопкаВыполнитьНажатие(Кнопка)

Для каждого Узла Из Узлы Цикл 

УзелОбъект =  Узла.Узел.ПолучитьОбъект();

ДобСклад = УзелОбъект.ОтборПоСкладам.Получить();

СписокСкладов = ДобСклад.Отбор.Склад.Значение;

Для каждого Склад из Склады Цикл

СписокСкладов.Добавить(Склад.Склад);

КонецЦикла;

Хранилище = Новый ХранилищеЗначения(СписокСкладов, Новый СжатиеДанных());
УзелОбъект = Хранилище.Получить();
СписокСкладов = Хранилище.Получить();
УзелОбъект.Записать(); 
 
КонецЦикла;

КонецПроцедуры


Yandex
Возможно, вас также заинтересует
Реклама на портале
Нерекаемый
02.06.2017 16:33Ответ № 1

Забыл указать Узлы и Склады это Табличные части, из которых как раз таки я получаю Узлы и Склады которые надо записать

Подсказка: Вы можете добавить любую страничку в Избранное щелкнув по значку
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.