helpf.pro
Регистрация

v8.3: ограничить создание документов

Tatoshka
31.01.2018 17:08Прочитано: 176

Добрый день,как ограничить создание документов не больше 75 в день, если пул превышен переносить документы наследующий день, при этом если на следующий день пул превышен переносить дальше и тд, сделала ограничение на создание в 1 день, как прописать условие на остальные, в голову ни чего вообще не приходит

Yandex
Возможно, вас также заинтересует
Реклама на портале
all4cf
31.01.2018 23:53Ответ № 1

Перед записью в модуле объекта проверяй запросом сколько документов есть за сегодня. если больше 75, то дата +1 день

вроде все просто )

Tatoshka
01.02.2018 11:20Ответ № 2
Tatoshka
01.02.2018 11:21Ответ № 3

я так и сделала, только при создании на сервере, но если пул на следующий день забился от не прибавляет 2 дня

all4cf
01.02.2018 14:47Ответ № 4

примерно так:

Код 1C v 8.3
 Если ДокСегодня<75 Тогда
//все ок
Иначе //>75 сегодня
   Если ДокЗавтра<75 Тогда
   такДатаДок+1 день
   Иначе //>75 завтра
      Если ДокПослеЗавтра<75 Тогда
         такДатаДок+2 день
       Иначе //>75 после завтра
//проверка на 3 дня и так далее
       КонецЕсли;
   КонецЕсли;
КонецЕсли;
Tatoshka
02.02.2018 16:25Ответ № 5

Суть задачи, есть документ с реквизитом УчетныйДень, вот по нему необходимо сделать отбор, если с такой датой доков больше 75 тогда + день, и так каждый раз, при чем если это пятница тогда на понедельник,   Я сделала следующее, запросом вытаскиваю пул доков за этот учетныйдень, если их количество больше 75 тогда + день, если текущий день пятница тогда + 3 дня, причем доки создаются уже с учетным днем + 1, не отрабатывает когда следующего дня пул переваливает за 75, может не правильно запрос написан, что берет только за сутки

Подсказка: Для редактирования своего ответа щелкните по значку (справа)
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.