helpf.pro
Регистрация

v8.3: Подскажите по этой ошибке.

Фыф
25.05.2018 15:07Прочитано: 140

Процедура ОтчетПоПоступлениямМатериалов(ТабДок) Экспорт

//{{КОНСТРУКТОР_ВЫХОДНЫХ_ФОРМ(ОтчетПоПоступлениямМатериалов)

// Данный фрагмент построен конструктором.

// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

Если ПоВсем=Истина тогда

Макет = ОтчетОбъект.ПолучитьМакет("ОтчетПоПоступлениямМатериалов");

Запрос = Новый Запрос;

Запрос.Текст =

"ВЫБРАТЬ

|МатериалыОбороты.ДатаД КАК ДатаД,

|МатериалыОбороты.Поставщик КАК Поставщик,

|ПРЕДСТАВЛЕНИЕ(МатериалыОбороты.Поставщик),

|МатериалыОбороты.Материал,

|ПРЕДСТАВЛЕНИЕ(МатериалыОбороты.Материал),

|МатериалыОбороты.Цена,

|МатериалыОбороты.ЕдиницаИзмерения,

|ПРЕДСТАВЛЕНИЕ(МатериалыОбороты.ЕдиницаИзмерения),

|МатериалыОбороты.КоличествоОборот КАК КоличествоОборот,

|МатериалыОбороты.СуммаОборот КАК СуммаОборот

|ИЗ

|РегистрНакопления.Материалы.Обороты КАК МатериалыОбороты

|

|УПОРЯДОЧИТЬ ПО

|ДатаД,

|Поставщик

|ИТОГИ

|СУММА(КоличествоОборот),

|СУММА(СуммаОборот)

|ПО

|ОБЩИЕ,

|ДатаД,

|Поставщик

|АВТОУПОРЯДОЧИВАНИЕ";

Если ПоВсем=Ложь тогда

Макет = ОтчетОбъект.ПолучитьМакет("ОтчетПоПоступлениямМатериалов");

Запрос = Новый Запрос;

Запрос.Текст =

"ВЫБРАТЬ

|МатериалыОбороты.ДатаД КАК ДатаД,

|МатериалыОбороты.Поставщик КАК Поставщик,

|ПРЕДСТАВЛЕНИЕ(МатериалыОбороты.Поставщик),

|МатериалыОбороты.Материал,

|ПРЕДСТАВЛЕНИЕ(МатериалыОбороты.Материал),

|МатериалыОбороты.Цена,

|МатериалыОбороты.ЕдиницаИзмерения,

|ПРЕДСТАВЛЕНИЕ(МатериалыОбороты.ЕдиницаИзмерения),

|МатериалыОбороты.КоличествоОборот КАК КоличествоОборот,

|МатериалыОбороты.СуммаОборот КАК СуммаОборот

|ИЗ

|РегистрНакопления.Материалы.Обороты КАК МатериалыОбороты

|ГДЕ

| МатериалыОбороты.Поставщик =Поставщик

|

|УПОРЯДОЧИТЬ ПО

|ДатаД,

|Поставщик

|ИТОГИ

|СУММА(КоличествоОборот),

|СУММА(СуммаОборот)

|ПО

|ОБЩИЕ,

|ДатаД,

|Поставщик

|АВТОУПОРЯДОЧИВАНИЕ";

КонецЕсли;

Запрос.УстановитьПараметр("Поставщик", Поставщик);

РезультатЗапроса = Запрос.Выполнить();

ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");

ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");

ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");

ОбластьПодвалТаблицы = Макет.ПолучитьОбласть("ПодвалТаблицы");

ОбластьОбщийИтог = Макет.ПолучитьОбласть("ОбщиеИтоги");

ОбластьДатаД = Макет.ПолучитьОбласть("ДатаД");

ОбластьПоставщик = Макет.ПолучитьОбласть("Поставщик");

ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");

ТабДок.Очистить();

ТабДок.Вывести(ОбластьЗаголовок);

ТабДок.Вывести(ОбластьШапкаТаблицы);

ТабДок.НачатьАвтогруппировкуСтрок();

ВыборкаОбщийИтог = РезультатЗапроса.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

ВыборкаОбщийИтог.Следующий();// Общий итог

ОбластьОбщийИтог.Параметры.Заполнить(ВыборкаОбщийИтог);

ТабДок.Вывести(ОбластьОбщийИтог, ВыборкаОбщийИтог.Уровень());

ВыборкаДатаД = ВыборкаОбщийИтог.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

Пока ВыборкаДатаД.Следующий() Цикл

ОбластьДатаД.Параметры.Заполнить(ВыборкаДатаД);

ТабДок.Вывести(ОбластьДатаД, ВыборкаДатаД.Уровень());

ВыборкаПоставщик = ВыборкаДатаД.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

Пока ВыборкаПоставщик.Следующий() Цикл

ОбластьПоставщик.Параметры.Заполнить(ВыборкаПоставщик);

ТабДок.Вывести(ОбластьПоставщик, ВыборкаПоставщик.Уровень());

ВыборкаДетальныеЗаписи = ВыборкаПоставщик.Выбрать();

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл

ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетальныеЗаписи);

ТабДок.Вывести(ОбластьДетальныхЗаписей, ВыборкаДетальныеЗаписи.Уровень());

КонецЦикла;

КонецЦикла;

КонецЦикла;

КонецЕсли;

ТабДок.ЗакончитьАвтогруппировкуСтрок();

ТабДок.Вывести(ОбластьПодвал);

ТабДок.Вывести(ОбластьПодвалТаблицы);

//}}КОНСТРУКТОР_ВЫХОДНЫХ_ФОРМ

КонецПроцедуры

Выдаёт ошибку:

{Отчет.ОтчетПоПоступлениямМатериалов.Форма.ОтчетПоПоступлениямМатериалов.Форма(130)}: Ошибка при вызове метода контекста (Вывести)

ТабДок.Вывести("ОбластьПодвал");

по причине:

Несоответствие типов (параметр номер '1')

{Отчет.ОтчетПоПоступлениямМатериалов.Форма.ОтчетПоПоступлениямМатериалов.Форма(130)}: Ошибка при вызове метода контекста (Вывести)

ТабДок.Вывести("ОбластьПодвал");

по причине:

Несоответствие типов (параметр номер '1')

Понимаю, что нужно где_то вроде как поставить 1 в области, но даже, когда ставлю ТабДок.ОбластьПодвал1 он также выдаёт такую же ошибку.

Спасибо за ваш ответ.

Yandex
Возможно, вас также заинтересует
Реклама на портале
Stref75
29.05.2018 11:33Ответ № 1

Меня смущает что ТабДок.Вывести("ОбластьПодвал") в кавычках.

Вывести(<Таблица>, <Уровень>, <ИмяГруппы>, <Открыта>)

Параметры:

<Таблица> (обязательный)

Тип: ТабличныйДокумент; ПолеТабличногоДокумента. Выводимая таблица.

а у вас строка

Подсказка: Щелкнув по значку (справа от названия вопроса), вы получите список ответов на похожие вопросы!
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.