helpf.pro
Регистрация

v8.3: Кнопка с командой.

Neron4000
31.05.2018 13:53Прочитано: 123

Здравствуйте. Имеется Документ Экзамен. С реквизитами Дата, Группа и Специальность. С табличной частью ОценочныйЛист (реквизиты: Студент, Критерий 1, Критерий 2, Критерий 3)

Требуется кнопка на форме, по нажатию которой заполняется табличная часть. А именно, выводятся имена всех студентов из указанной в реквизитах документа группы (без заполнения критериев).

Я создаю команду ВывестиСтудентов и задаю действие в модуле формы

Пишу:

Код 1C v 8.3
 &НаКлиентеПроцедура ВывестиСтудентов(Команда)   // Вставить содержимое обработчика.   Заполнение(Объект.ОценочныйЛист);КонецПроцедуры   
Код 1C v 8.3
 Функция Заполнение(НоваяСтрока)   Выборка = Справочники.Студенты.Выбрать();      Пока Выборка.Следующий() Цикл          Если Объект.Группа = Выборка.Группа Тогда              НоваяСтрока = Элементы.ОценочныйЛист.ДобавитьСтроку();       НоваяСтрока.Студент = Выборка.Наименование;     КонецЕсли   КонецЦикла;       КонецФункции   

Подозреваю, что многое неверно, но при запуске отладки ошибок не видит.Однако, при нажатии этой кнопки с командой выдает ошибку:

{Документ.Экзамен.Форма.ФормаДокумента.Форма(27)}: Обращение к процедуре объекта как к функции (ДобавитьСтроку) НоваяСтрока = Элементы.ОценочныйЛист.ДобавитьСтроку();

Yandex
Возможно, вас также заинтересует
Реклама на портале
vidyakin
15.06.2018 18:14Ответ № 1

Надо не к элементам формы обращаться, а к данным, при добавлении строк

Подсказка: Для выделения Кода используйте (в редакторе).
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.