helpf.pro
Регистрация

v8.3: Кнопка с командой.

Neron4000
31.05.2018 13:54Прочитано: 213

Здравствуйте. Имеется Документ Экзамен. С реквизитами Дата, Группа и Специальность. С табличной частью ОценочныйЛист (реквизиты: Студент, Критерий 1, Критерий 2, Критерий 3)

Требуется кнопка на форме, по нажатию которой заполняется табличная часть. А именно, выводятся имена всех студентов из указанной в реквизитах документа группы (без заполнения критериев).

Я создаю команду ВывестиСтудентов и задаю действие в модуле формы

Пишу:

Код 1C v 8.3
 &НаКлиентеПроцедура ВывестиСтудентов(Команда)   // Вставить содержимое обработчика.   Заполнение(Объект.ОценочныйЛист);КонецПроцедуры   
Код 1C v 8.3
 Функция Заполнение(НоваяСтрока)   Выборка = Справочники.Студенты.Выбрать();      Пока Выборка.Следующий() Цикл          Если Объект.Группа = Выборка.Группа Тогда              НоваяСтрока = Элементы.ОценочныйЛист.ДобавитьСтроку();       НоваяСтрока.Студент = Выборка.Наименование;     КонецЕсли   КонецЦикла;       КонецФункции   

Подозреваю, что многое неверно, но при запуске отладки ошибок не видит.Однако, при нажатии этой кнопки с командой выдает ошибку:

{Документ.Экзамен.Форма.ФормаДокумента.Форма(27)}: Обращение к процедуре объекта как к функции (ДобавитьСтроку) НоваяСтрока = Элементы.ОценочныйЛист.ДобавитьСтроку();

Yandex
Возможно, вас также заинтересует
Реклама на портале
Neron4000
31.05.2018 14:08Ответ № 1

VoronovMV
01.06.2018 11:48Ответ № 2

Вместо НоваяСтрока = Элементы.ОценочныйЛист.ДобавитьСтроку(); НоваяСтрока = ОценочныйЛист.Добавить();

Если таблица находится на в объекте;

 НоваяСтрока = Объект.ОценочныйЛист.Добавить();

Stref75
05.06.2018 06:29Ответ № 3

Если в Выбрать добавить отбор по группе, то можно получить сразу выборку нужных студентов и в цикле не проверять условие на принадлежность студента к группе

Код 1C v 8.3
 Выборка = Справочники.Студенты.Выбрать();   
Подсказка:Вы можете добавить любую страничку в Социальные закладки щелкнув по значку соцсетей (в вверху)
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.