helpf.pro
Регистрация

v7: Как создать реквизит формы документа, связанного со списком возможных значений

leonid_gun
16.01.2019 01:22Прочитано: 885

Здравствуйте. 

ТиС 032. платформа 7.7 027 Есть необходимость создать в форме реквизит документа тип Строка, который будет связан с выпадающим списком, из которого можно выбрать одно значение из многих для этого реквизита, с последующим сохранением этого значения. И при открытии сохраненного документа этот реквизит отображал сохраненное значение. Как можно правильно такое реализовать?

Попробовал по подсказке ребят с другого форума(спасибо им!) реквизит с кнопкой выбора. 

Немного продвинулся с кодом но это работает с реквизитом документа тип Строка 

Процедура ИзмПрозрачность()

СпЗн = СоздатьОбъект("СписокЗначений");
СпЗн.ДобавитьЗначение("прозрачная","прозрачная");
СпЗн.ДобавитьЗначение("непрозрачная","непрозрачная");
Зн = 0;
Если СпЗн.ВыбратьЗначение(Зн,"Прозрачность биоматериала",,,1) = 1 Тогда
Прозрачность = Зн; КонецЕсли; КонецПроцедуры
//и далее


Процедура ПриНачалеВыбораЗначения(Рекв,ФлагСтандОбр)// предопределенная
Если Рекв = "Прозрачность" Тогда
ИзмПрозрачность()
КонецЕсли;
КонецПроцедуры [/pre]

А вот как быть если обрабатываем список для реквизита тип Число, еще и с дробной частью? ))

при выборе "педальки" список выводится, но при выборе значения из списка, выпадает экранная цифровая калава, стандартная для цифрового поля ввода с кнопкой. Нужно менять тип на Строку? Но хотелось бы оставить ограничение по разрядности для проверки ввода от руки.
Yandex
Возможно, вас также заинтересует
Реклама на портале
leonid_gun
16.01.2019 16:05Ответ № 1

Вот это 

ФлагСтандОбр = 0;[/pre] в теле предопределенной процедуре как раз и помогло!! Перестала появляться экранная цифровая клава на реквизитах типа Число. То что нужно )))
leonid_gun
16.01.2019 23:34Ответ № 2

хотя если реквизит тип Число с дробной частью, тогда число из списка выбирается только его целая часть. А надо, чтобы было полностью и целая м дробная части. Не знаю как это победить не переводя сам реквизит в тип Строка ((

leonid_gun
16.01.2019 23:59Ответ № 3

Догнал. Надо просто использовать децимальный знак точку, а не запятую в списке значений. Вот тупанул ((

Подсказка: Щелкнув по значку (справа от названия вопроса), вы получите список ответов на похожие вопросы!
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.