helpf.pro
Регистрация

v8.3: Значение из списка значений выпадающего списка не отображается в поле формы.

Ledgik
15.02.2019 12:24Прочитано: 6029

Есть два справочника Штатное и Подразделения. В справочнике Штатное есть автоматически генерируемое поле Наименование. Как программно сделать так чтобы в поле Наименование справочника Штатное выводились списком значений из поля Наименование справочника Подразделения? Я только начал изучать программирование в 1С. Есть  одна закавыка: Выпадающий список на форме формируется и привязывается к справочнику Подразделения, только когда выбираю то или иное значение из списка значений оно не отображается в поле формы. Можете помочь разобраться в этом?

Код 1C v 8.3
 &НаСервере
Функция Наименование();
       
    Запрос = Новый Запрос;
   
        Запрос.Текст =
       
            "ВЫБРАТЬ
            |   Подразделения.Наименование КАК Наименование,
            |   Подразделения.ЭтоГруппа,
            |   Подразделения.Родитель
            |ИЗ
            |   Справочник.Подразделения КАК Подразделения
            |ГДЕ
            |   Подразделения.ЭтоГруппа = Ложь
            |   И Подразделения.Родитель =Родитель";
           
        Запрос.УстановитьПараметр("Родитель", Справочники.Подразделения.НайтиПоНаименованию("Наименование"));
       
        РезультатЗапроса = Запрос.Выполнить();
   
   
    Список = Новый СписокЗначений;    
    Список.ЗагрузитьЗначения(РезультатЗапроса.Выгрузить().ВыгрузитьКолонку("Наименование"));
    Возврат Список;
   
КонецФункции
 
&НаКлиенте
Процедура НаименованиеНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    Объект.Наименование=ВыбратьИзСписка(Наименование(), Элементы.Наименование);
КонецПроцедуры
Yandex
Возможно, вас также заинтересует
Реклама на портале
Ledgik
17.02.2019 14:52Ответ № 1
Код 1C v 8.3
 &НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
   
    Элементы.Наименование.СписокВыбора.Очистить();
   
    Запрос = Новый Запрос;
   
    Запрос.Текст =
   
      "ВЫБРАТЬ
           |   Подразделения.Наименование КАК Наименование,
           |   Подразделения.ЭтоГруппа,
           |   Подразделения.Родитель
           |ИЗ
           |   Справочник.Подразделения КАК Подразделения
           |ГДЕ
           |   Подразделения.ЭтоГруппа = Ложь
           |   И Подразделения.Родитель =Родитель";
           
        Запрос.УстановитьПараметр("Родитель", Справочники.Подразделения.НайтиПоНаименованию("Наименование"));
   
    РезультатЗапроса = Запрос.Выполнить();
    выборка = РезультатЗапроса.Выбрать();
   
    Пока Выборка.Следующий() Цикл
         Элементы.Наименование.СписокВыбора.Добавить(Выборка.Наименование, Выборка.Наименование);  
    КонецЦикла;
   
КонецПроцедуры


Все уже решил этот вопрос с помощью других программистов.
Ledgik
17.02.2019 14:53Ответ № 2
Вопрос закрыт!
Подсказка: Щелкнув по значку (справа от названия вопроса), вы получите список ответов на похожие вопросы!
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.