helpf.pro
Регистрация

v8.3:

Ledgik
22.02.2019 14:56Прочитано: 34

Написал код для расчета разности дат. Результат выводит значение в днях. Помогите преобразовать код так чтобы результат выводился вот так: 5 лет 3 месяца 11 дней. Код привожу ниже.

Код 1C v 8.3
 &НаСервереПроцедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)   ТекущаяДата = НачалоДня(ТекущаяДата());КонецПроцедуры   
Код 1C v 8.3
 &НаКлиентеПроцедура ТЧСотрудникДатаНачалаПриИзменении(Элемент)    Стр = Элементы.ТЧСотрудник.ТекущиеДанные;      ДатаНачала = НачалоДня(Элемент.ТЧСотрудник.ДатаНачала());КонецПроцедуры   
Код 1C v 8.3
 &НаКлиентеПроцедура ТЧСотрудникДатаОкончанияПриИзменении(Элемент)   Стр = Элементы.ТЧСотрудник.ТекущиеДанные;      ДатаОкончания = НачалоДня(Элемент.ТЧСотрудник.ДатаОкончания());КонецПроцедуры   
Код 1C v 8.3
 &НаКлиентеПроцедура ТЧСотрудникТекущаяДатаПриИзменении(Элемент)   Стр = Элементы.ТЧСотрудник.ТекущиеДанные;   ТекущаяДата = НачалоДня(Элемент.ТЧСотрудник.ТекущаяДата());   КонецПроцедуры   
Код 1C v 8.3
 &НаКлиентеПроцедура ТЧСотрудникСтажРаботыПриИзменении(Элемент)   Стр = Элементы.ТЧСотрудник.ТекущиеДанные;   СтажРаботы = Элемент.ТЧСотрудник.СтажРаботы;КонецПроцедуры   

&НаКлиентеПроцедура ПередЗаписью(Отказ, ПараметрыЗаписи) Стр = Элементы.ТЧСотрудник.ТекущиеДанные; Если НЕ ЗначениеЗаполнено(Стр.ДатаОкончания) Тогда Стр.СтажРаботы = (ТекущаяДата()-Стр.ДатаНачала)/(60*60*24); Иначе Стр.СтажРаботы = (Стр.ДатаОкончания-Стр.ДатаНачала)/(60*60*24); КонецЕсли; КонецПроцедуры

Yandex
Возможно, вас также заинтересует
Реклама на портале
Подсказка: Для быстрого перемещения к последнему ответу или к вопросу используйте или .
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.