helpf.pro
Регистрация

Общие модули ЭКСПОРТ

Bell
17.11.2010 19:52Прочитано: 1606
Здравствуйте
Подскажите как экспортировать
А то у меня то много параметров, то не хватает, то выводит только пропись числа

// Прописью рубли копейки цифрой
Функция РублиКопейки(??????) Экспорт
ФормСтрока = "Л = ru_RU; ДП = Истина";
ПарПредмета="рубль, рубля, рублей, м, копейка, копейки, копеек, ж";
ЧислоПрописью(?????,ФормСтрока,ПарПредмета);
КонецФункции
Yandex
Возможно, вас также заинтересует
Реклама на портале
bugor666
18.11.2010 08:23Ответ № 1
Это твоя собственная переменная. Как ты ее назовешь - не важно.
Код 1C v 8.х
 Функция РублиКопейки(НеважноКакоеСлово) Экспорт
ФормСтрока = "Л = ru_RU; ДП = Истина";
ПарПредмета="рубль, рубля, рублей, м, копейка, копейки, копеек, ж";
ЧислоПрописью(НеважноКакоеСлово,ФормСтрока,ПарПредмета);
КонецФункции

Вызов функции делай так:
Код 1C v 8.х
 СуммаСтрокой = РублиКопейки(Сумма);   

И будет тебе счастье.
bugor666
18.11.2010 08:38Ответ № 2
Кстати! Только сейчас обратил внимание...
Код 1C v 8.х
 Функция РублиКопейки(НеважноКакоеСлово) Экспорт
ФормСтрока = "Л = ru_RU; ДП = Истина";
ПарПредмета="рубль, рубля, рублей, м, копейка, копейки, копеек, ж";
Возврат ЧислоПрописью(НеважноКакоеСлово,ФормСтрока,ПарПредмета);
КонецФункции


...иначе как функция вернет результат?... *13
Bell
18.11.2010 16:20Ответ № 3
БОЛЬШОЕ ВАМ СПАСИБО
bugor666
22.11.2010 08:17Ответ № 4
Вопрос закрыт!
Подсказка: Для быстрого поиска ответов - используйте 'Поиск'
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.