helpf.pro
Регистрация

v8: 1. На форму обработки добавить новую кнопку Создать массив чисел По нажатию к

Nertoic1c
16.04.2019 06:16Прочитано: 899
Yandex
Возможно, вас также заинтересует
Реклама на портале
Nertoic1c
16.04.2019 10:28Ответ № 1

На форму обработки добавить новую кнопку "Создать массив чисел"По нажатию кнопки должен создаваться массив "МассивЧисел". Данный массив должен содержать числа от 1000 до 10000

2. Добавить Массив Чисел В МассивТиповДанных

3. Удалить из МассиваЧисел все нечетные числа

red_phanthom
17.04.2019 07:41Ответ № 2
Код 1C v 8.2 УП
 	Массивчик = новый массив;
ГСЧ = Новый ГенераторСлучайныхЧисел();

//Создание массива рандомных чисел
Для сч = 1 По 100 Цикл
СлучайноеЧисло = ГСЧ.СлучайноеЧисло(1000, 10000);
Массивчик.Добавить(СлучайноеЧисло);
Сообщить(Массивчик[сч-1]);
КонецЦикла;

//удаление нечетных
ДлинаМассива = Массивчик.Количество()-1;
ДлинаМассива = -ДлинаМассива;
Для индексик = ДлинаМассива по 0 цикл
Если Массивчик[-индексик]%2=1 тогда
Массивчик.Удалить(-индексик);
КонецЕсли;
КонецЦикла;

Сообщить("______________________________");
//Вывод обработанного массива
Для Каждого ЭлементМассива из Массивчик Цикл
        Сообщить(ЭлементМассива); 
    КонецЦикла;


red_phanthom
17.04.2019 07:43Ответ № 3
Код 1C v 8.2 УП
 	Массивчик = новый массив;
ГСЧ = Новый ГенераторСлучайныхЧисел();

//Создание массива рандомных чисел
Для сч = 1 По 100 Цикл
СлучайноеЧисло = ГСЧ.СлучайноеЧисло(1000, 10000);
Массивчик.Добавить(СлучайноеЧисло);
Сообщить(Массивчик[сч-1]);
КонецЦикла;

//удаление нечетных
ДлинаМассива = Массивчик.Количество()-1;
ДлинаМассива = -ДлинаМассива;
Для индексик = ДлинаМассива по 0 цикл
Если Массивчик[-индексик]%2=1 тогда
Массивчик.Удалить(-индексик);
КонецЕсли;
КонецЦикла;

Сообщить("______________________________");
//Вывод обработанного массива
Для Каждого ЭлементМассива из Массивчик Цикл
Сообщить(ЭлементМассива);
КонецЦикла;
Подсказка: Вы получили ответ на свой вопрос - закройте вопрос!
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.