helpf.pro
Регистрация

v8: Подсчитать сколько раз последняя буква 1 слова встречается во 2 слове

marishka1903
09.10.2019 10:54Прочитано: 85

Программа, подсчитывающая, сколько раз последняя буква слова Х встречается в слове У.

Код 1C v 8.3
 
&НаКлиенте
Процедура Задание1(Команда)
Перем a;
Перем b;
ВвестиСтроку(a, "Введите 1 слово:",,);
ВвестиСтроку(b, "Введите 2 слово:",,);
ПоследнийСимвол = Прав(a,1);
Сообщить ("Первое слово - " + a + " , Второе слово - "+ b +" . Ищем символ *" + ПоследнийСимвол +"* во 2 слове");
Результат = СтрЧислоВхождений (b,ПоследнийСимвол);
Сообщить("В слове "+b+" буква "+ПоследнийСимвол+" встречается " +Результат+" раз.");
КонецПроцедуры

Как исправить и написать с помощью цикла? Помогите пожалуйста Возможно как то так (ниже), но не работает

Код 1C v 8.3
 Перем Слово1;
 Перем Слово2;
 ВвестиСтроку (Слово1, "Введите 1 слово:",,);
 ВвестиСтроку (Слово2, "Введите 2 слово:",,);
 ПоследнийСимвол = Прав(Слово1,1);
 ДлинаСлова = СтрДлина(Слово2);
 Счетчик = 0;
 Для i = 1 По ДлинаСлова Цикл
  Если ПоследнийСимвол = Слово2 Тогда
   Счетчик = Счетчик+1;
  КонецЕсли;
 КонецЦикла;
 Сообщить(Счетчик);
Yandex
Возможно, вас также заинтересует
Реклама на портале
Подсказка: Вы можете приложить к ответу файл или изображение щелкнув по значку или в редакторе.
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.