helpf.pro
Регистрация

v8:

Khronos
04.01.2020 20:49Прочитано: 27

Здравствуйте уважаемые программисты)

Стараюсь парсить XML файл Мне нужно получить только раздел USD.

На данный момент запрос выглядит вот так. Данные получает правильно. Но как получить эти данные отдельно, чтобы допустим name получить отдельно. И чтобы выводились только те, у кого в CODE прописан USD

Код
ЧтениеХМЛ = Новый ЧтениеXML;

ЧтениеХМЛ.ОткрытьФайл("https://www.cbar.az/currencies/30.12.2019.xml");

Пока ЧтениеХМЛ.Прочитать() Цикл

Если ЧтениеХМЛ.ТипУзла = ТипУзлаXML.НачалоЭлемента И ЧтениеХМЛ.Имя = "ValType" Тогда

продолжить;

КонецЕсли;

Если ЧтениеХМЛ.ТипУзла = ТипУзлаXML.НачалоЭлемента И ЧтениеХМЛ.Имя = "Valute" Тогда

ЧтениеХМЛ.ПрочитатьАтрибут();

СтрокаОценка = "Valute: " + ЧтениеХМЛ.ЗначениеАтрибута("Code");

КонецЕсли;

Если ЧтениеХМЛ.ТипУзла = ТипУзлаXML.НачалоЭлемента И ЧтениеХМЛ.Имя = "Name" Тогда

Сообщить(СтрокаОценка);

КонецЕсли;

//Если ЧтениеХМЛ.ЗначениеАтрибута("Code") = "USD" Тогда

Если ЧтениеХМЛ.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда

ИмяЭлемента = ЧтениеХМЛ.Имя;

ИначеЕсли ЧтениеХМЛ.ТипУзла = ТипУзлаXML.Текст Тогда

Сообщить(ИмяЭлемента + ": " + ЧтениеХМЛ.Значение);

КонецЕсли;

Если ЧтениеХМЛ.ТипУзла = ТипУзлаXML.КонецЭлемента И ЧтениеХМЛ.Имя = "АдресСайта" Тогда

Сообщить("--------------------------------");

КонецЕсли;

//КонецЕсли;

КонецЦикла;

ЧтениеХМЛ.Закрыть();

Yandex
Возможно, вас также заинтересует
Реклама на портале
Подсказка:Вы можете добавить любую страничку в Социальные закладки щелкнув по значку соцсетей (в вверху)
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.