helpf.pro
Регистрация

v8.3: Странная раскраска календаря

IgorRet
09.02.2020 19:51Прочитано: 155

Подскажите, что в этом коде не так ? Процедура Реквизит1ПриВыводеПериода(Элемент, ОформлениеПериода) Для каждого ТекущийДень из ОформлениеПериода.Даты Цикл

Если ТекущийДень.Дата = Дата ("07.02.2020 00:00:00") Тогда ТекущийДень.ЦветТекста = Новый Цвет (255, 0, 0); КонецЕсли;

//ЭтотДень = ЗапросСвойстваДаты (ТекущийДень.Дата); //Если ЭтотДень Тогда // ТекущийДень.ЦветТекста = Новый Цвет (255, 0, 0); //КонецЕсли;

КонецЦикла;

КонецПроцедуры

После выполнения процедуры седьмое февраля окрашивается в красный цвет, а все остальные дня месяца в черный. При этом также меняется и шрифт цифр. Оформление других месяцев остается без изменений

Yandex
Возможно, вас также заинтересует
Реклама на портале
Подсказка: Щелникни по Имени пользователя напротив ответа, и тем самым покажешь, что сообщение адресовано ему.
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.