helpf.pro
Регистрация

v8: Как распечатать выделенные док-ты из формы списка сразу на принтер

lambert
08.03.2020 12:15Прочитано: 32

Добрый день!

Помогите распечатать выделенные документы "Реализация товаров и услуг" из формы списка документов без предварительного просмотра сразу на принтер с количеством копий по 2 экземпляра.

Написал в модуле Формы списка Процедуру.

Процедура ДействиеГрупповаяПечать(Кнопка)

ВыделенныеСтроки = ЭлементыФормы.Список.ВыделенныеСтроки;

Если ВыделенныеСтроки.Количество() = 0 Тогда

Возврат;

КонецЕсли;

Массив = Новый Массив;

Для каждого ВыделеннаяСтрока Из ВыделенныеСтроки Цикл

УниверсальныеМеханизмы.НапечататьДокументИзФормыСписка(ВыделеннаяСтрока.Ссылка.ПолучитьОбъект());

КонецЦикла;

КонецПроцедуры

Если так, то открывается предварительный просмотра каждого документа.

А, надо, чтобы автоматом на принтер.

Yandex
Возможно, вас также заинтересует
Реклама на портале
Подсказка: Для быстрого перемещения к последнему ответу или к вопросу используйте или .
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.