helpf.pro
Регистрация

v8.3: Вывод даты дата в макете прописью

ru_spaik
30.03.2020 03:45Прочитано: 2653
Код 1C v 8.3
 Процедура Печать(ТабДок, Ссылка) Экспорт
//{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
Макет = Документы.Заявка.ПолучитьМакет("Макет");
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| Заявка.ДатаЗаявки КАК ДатаЗаявки,
| Заявка.Номер КАК Номер,
| Заявка.ОбьектСтроительства КАК ОбьектСтроительства,
| Заявка.Составил КАК Составил,
| Заявка.Шифр КАК Шифр,
| Заявка.Материалы.(
| НомерСтроки КАК НомерСтроки,
| Номенклатура КАК Номенклатура,
| КоличествоКПолучению КАК КоличествоКПолучению,
| Номенклатура.ЕдИзм КАК НоменклатураЕдИзм,
| Номенклатура.Артикул1C КАК НоменклатураАртикул1C
| ) КАК Материалы,
| Заявка.Составил.должность КАК Составилдолжность,
| NULL КАК Поле1,
| Заявка.Составил.доверенность КАК Составилдоверенность,
| Заявка.ОбьектСтроительства.Договор КАК ОбьектСтроительстваДоговор,
| Заявка.ОбьектСтроительства.ВидРабот КАК ОбьектСтроительстваВидРабот
|{ВЫБРАТЬ
| ДатаЗаявки,
| Номер,
| ОбьектСтроительства.*,
| Составил.*,
| Шифр,
| Материалы,
| НоменклатураЕдИзм,
| НоменклатураАртикул1C}
|ИЗ
| Документ.Заявка КАК Заявка
|ГДЕ
| Заявка.Ссылка В(&Ссылка)";
Запрос.Параметры.Вставить("Ссылка", Ссылка);
Выборка = Запрос.Выполнить().Выбрать();
ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");

Шапка = Макет.ПолучитьОбласть("Шапка");
ОбластьМатериалыШапка = Макет.ПолучитьОбласть("МатериалыШапка");
ОбластьМатериалы = Макет.ПолучитьОбласть("Материалы");
Подвал = Макет.ПолучитьОбласть("Подвал");
ТабДок.Очистить();
ВставлятьРазделительСтраниц = Ложь;
Пока Выборка.Следующий() Цикл
Если ВставлятьРазделительСтраниц Тогда
ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
КонецЕсли;

ТабДок.Вывести(ОбластьЗаголовок);

Шапка.Параметры.Заполнить(Выборка);
  
ТабДок.Вывести(Шапка, Выборка.Уровень());
ТабДок.Вывести(ОбластьМатериалыШапка);
ВыборкаМатериалы = Выборка.Материалы.Выбрать();
Пока ВыборкаМатериалы.Следующий() Цикл
ОбластьМатериалы.Параметры.Заполнить(ВыборкаМатериалы);
ТабДок.Вывести(ОбластьМатериалы, ВыборкаМатериалы.Уровень());
КонецЦикла;

Подвал.Параметры.Заполнить(Выборка);
ТабДок.Вывести(Подвал);
ВставлятьРазделительСтраниц = Истина;
КонецЦикла;
//}}
КонецПроцедуры
Yandex
Возможно, вас также заинтересует
Реклама на портале
ru_spaik
30.03.2020 03:48Ответ № 1

При формировании печати в макете выводит дату в формате: 13.07.2019 0:00:00 . А мне хотелось бы только месяц прописью и  год.  Помогите советом. в коде нужно добавить. Весь интернет перерыл! не могу понять куда вписать код по формированию формата даты.

PahaB
30.03.2020 06:22Ответ № 2

ДатаПрописью = Формат(Дата, "ДФ=""дд ММММ гггг 'г.'""");

ru_spaik
30.03.2020 06:45Ответ № 3

А можете подсказать в каком месте кода добавить нужно ?

PahaB
30.03.2020 07:26Ответ № 4

макета не видно, поэтому в том цикле, где выводится дата после этих строк  Шапка.Параметры.Заполнить(Выборка); или Подвал.Параметры.Заполнить(Выборка);

ru_spaik
30.03.2020 07:38Ответ № 5

ru_spaik
30.03.2020 07:41Ответ № 6

После ввода пишет что переменной такой нет.

{Документ.Заявка.МодульМенеджера(53,25)}: Переменная не определена (Дата)

ДатаПрописью = Формат(<<?>>Дата, "ДФ=""дд ММММ гггг 'г.'"""); (Проверка: Сервер)

{Документ.Заявка.МодульМенеджера(53,25)}: Переменная не определена (ДатаЗаявки)

ДатаПрописью = Формат(<<?>>ДатаЗаявки, "ДФ=""дд ММММ гггг 'г.'"""); (Проверка: Сервер)

PahaB
30.03.2020 09:20Ответ № 7
Код 1C v 8.3
 Шапка.Параметры.Заполнить(Выборка);
Шапка.параметры.ДатаЗаявки = Формат(ДатаЗаявки, "ДФ=""дд ММММ гггг 'г.'""");
PahaB
30.03.2020 10:16Ответ № 8

в запросе сделай только по материалам, убери первый цикл и заполни руками параметры шапки. Так правильнее будет.

ru_spaik
30.03.2020 14:24Ответ № 9

Спасибо)) Помогло

ru_spaik
30.03.2020 15:22Ответ № 10
Вопрос закрыт!
Подсказка: Вы получили ответ на свой вопрос - закройте вопрос!
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.