helpf.pro
Регистрация

v8: Ввод текущих даты и времени по нажатию кнопки(или событие ПриИзменении) в ячейке

Sultalin
05.06.2020 12:46Прочитано: 113

Хочу сделать так, чтобы в табличной части документа (там присутствуют 3 колонки с реквезитами (ДатаНачала,ДатаЗавершения,ДатаПроверки) при срабатывании события ПриИзменении, в выбранную ячейку(где я добавил кнопку Очистить для простоты) автоматически прописывалась текущая дата и время. (Мне пришлось это все делать для дипломной работы, но так как у меня менеджмент(управление) программирования особо не было и в результате познания по 1с у меня слабые) Подскажите какой тип данных сделать у этих реквизитов и как через форму изменять данные выбранной ячейки на сервере.

(то что пока есть)

&НаСервере

Процедура НаименованиеПриИзмененииНаСервере()

Объект.Децимальное = Объект.Наименование.Децимальное_обозначение;

КонецПроцедуры

&НаКлиенте

Процедура НаименованиеПриИзменении(Элемент)

НаименованиеПриИзмененииНаСервере();

КонецПроцедуры

&НаСервере

Процедура ЗаполнитьНаСервере()

Запрос = Новый Запрос;

Запрос.Текст = "ВЫБРАТЬ ПЕРВЫЕ 40

|Децимальные_обозначенияОперации.НомерСтроки КАК Номер,

|Децимальные_обозначенияОперации.Операции КАК Операции,

|Децимальные_обозначенияОперации.Участок КАК Участок

|{ВЫБРАТЬ

|Операции,

|Операции,

|Участок.*}

|ИЗ

|Справочник.Децимальные_обозначения.Операции КАК Децимальные_обозначенияОперации

|ГДЕ

|Децимальные_обозначенияОперации.Ссылка.Децимальное_обозначение =Децимальное_обозначение

|

|ДЛЯ ИЗМЕНЕНИЯ";

Запрос.УстановитьПараметр("Децимальное_обозначение",Объект.Децимальное);

Результат = Запрос.Выполнить();

Объект.Таблица.Загрузить(Результат.Выгрузить());

КонецПроцедуры

&НаКлиенте

Процедура Заполнить(Команда)

ЗаполнитьНаСервере();

КонецПроцедуры

&НаСервере

Процедура ДатаПриИзмененииНаСервере()

Объект.Дата = ПолучитьОперативнуюОтметкуВремени();

КонецПроцедуры

Yandex
Возможно, вас также заинтересует
Реклама на портале
Подсказка: Вы можете приложить к ответу файл или изображение щелкнув по значку или в редакторе.
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.