helpf.pro
Регистрация

v8.3: Помогите с задачей с циклами

novi4ek
16.09.2020 12:33Прочитано: 180
Yandex
Возможно, вас также заинтересует
Реклама на портале
novi4ek
16.09.2020 12:35Ответ № 1

нужен еще один счетчик, в котором  будут накапливаться еженедельное количество (ВсегоЗаНеделю = ВсегоЗаНеделю + Дни).Как только он посчитает воскресенье (неделя вся рассчитана) - необходимо вывести значение этого еженедельного счетчика, после чего обнулить его и продолжить считать с понедельника.

novi4ek
16.09.2020 12:38Ответ № 2
Fearless
02.10.2020 06:15Ответ № 3
Код 1C v 8.3
 	Дни =  21;
ПротеинВБудни = 100;
ПротеинВВыходные = 200;
Всего = 0;
ПротеинВНеделю = 0;
ЧастотаПриема = 3;
Неделя = 0;


Для СчетчикДни = 1 по Дни Цикл
Если СчетчикДни % ЧастотаПриема = 0 Тогда
Если (СчетчикДни - Неделя * 7) % 6 = 0 или (СчетчикДни - Неделя * 7) % 7 = 0 Тогда 
Всего = Всего + ПротеинВВыходные;
ПротеинВНеделю = ПротеинВНеделю + ПротеинВВыходные;
Иначе 
Всего = Всего + ПротеинВБудни;
ПротеинВНеделю = ПротеинВНеделю + ПротеинВБудни;
КонецЕсли;
КонецЕсли;
Если СчетчикДни % 7 = 0 Тогда
Неделя = Неделя + 1;
Сообщить("Неделя " + Неделя + " = " + ПротеинВНеделю);
ПротеинВНеделю = 0;
КонецЕсли;
КонецЦикла;
Сообщить("Итого = " + Всего);

КонецПроцедуры


ProFanat
15.11.2020 17:23Ответ № 4

DANDRUFF IS AFRAID OF THIS SHAMPOO AS A FIRE: https://stopperhot.com

ProFanat
15.11.2020 17:24Ответ № 5

DANDRUFF IS AFRAID OF THIS SHAMPOO AS A FIRE: https://stopperhot.com

Подсказка: Для выделения Кода используйте (в редакторе).
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.