helpf.pro
Регистрация

v8.3: Проверка на уникальность имени

pin1986
10.01.2021 11:49Прочитано: 48

Доброго дня! Прошу не судить строго, я новичок в 1С - учусь!

Вопрос след. плана. нужен модуль для проверки уникальности имени в справочниках (номенклатура)- Создаю общий модуль

Код 1C v 8.3
 &НаСервере


Функция ПроверкаНаНаименование (Наименование) Экспорт

Имя = Справочники.Номенклатура.НайтиПоНаименованию(Наименование);
Если НЕ Имя.Пустая() Тогда 
Отказ = Истина;
Сообщить ("Такой элемент справочника уже существует");

   Возврат Истина;
   
КонецЕсли;
     


КонецФункции


В модуле объекта

Код 1C v 8.3
 

Процедура ПередЗаписью(Отказ)

Если Проверки.ПроверкаНаНаименование(Наименование)= Истина Тогда
Отказ = Истина;
 
      
КонецЕсли;

КонецПроцедуры


В итоге номенклатура с одинаковым именем не создается, но тогда и ничего не удаляется. Помогите, пожалуйста.

Yandex
Возможно, вас также заинтересует
Реклама на портале
pin1986
17.01.2021 20:26Ответ № 1
Вопрос закрыт!
Подсказка: Для редактирования своего ответа щелкните по значку (справа)
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.