helpf.pro
Регистрация

v8: Подскажите с расшифровкой.

tqsiii
23.08.2022 13:34Прочитано: 122

Добрый день, никак не получается расшифровать ячейку макета в табличном документе, а именно указать какую ячейку и чем расшифровывать. Направьте, пожалуйста. Заранее спасибо!

Код 1C v 8.3
 РезультатЗапроса = Запрос.Выполнить();ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");ОбластьПодвалТаблицы = Макет.ПолучитьОбласть("ПодвалТаблицы");ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");МакетАнализ.Очистить();ОбластьЗаголовок.Параметры.Дата = ТекущаяДата();МакетАнализ.Вывести(ОбластьЗаголовок);МакетАнализ.Вывести(ОбластьШапкаТаблицы);МакетАнализ.НачатьАвтогруппировкуСтрок();ВыбИтог = РезультатЗапроса.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);Если ВыбИтог.Следующий() ТогдаОбластьПодвалТаблицы.Параметры.Заполнить(ВыбИтог);ВыборкаДетальныеЗаписи = ВыбИтог.Выбрать();Пока ВыборкаДетальныеЗаписи.Следующий() ЦиклОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетальныеЗаписи);МакетАнализ.Вывести(ОбластьДетальныхЗаписей, ВыборкаДетальныеЗаписи.Уровень());КонецЦикла;КонецЕсли;МакетАнализ.ЗакончитьАвтогруппировкуСтрок();МакетАнализ.Вывести(ОбластьПодвалТаблицы);КонецПроцедуры&НаКлиенте
Процедура МакетАнализОбработкаРасшифровки (Расшифровка, СтандартнаяОбработка)


Отчет = Отчеты.ОтчетДляРасшифровки.Создать();
ФормаОтчета = Отчет.ПолучитьФорму(, , );
ФормаОтчета.Открыть();

КонецПроцедуры
Yandex
Возможно, вас также заинтересует
Реклама на портале
Подсказка: Для быстрого перемещения к последнему ответу или к вопросу используйте или .
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.