helpf.pro
Регистрация

v8.3: Не отображается картинка в 1с

lkari12
11.04.2024 16:02Прочитано: 638

Такая проблема.При открытии формы, жму на кнопку загрузить картинку. Выбираю файл, он появляется на форме.

Жму записать, закрыть. Но при открытии, на форме нет изображения. Хотя было.Подскажите пожалуйста.&НаСервере

Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

АдресКартинки = ПолучитьНавигационнуюСсылку(Объект.Ссылка, "Изображение");

//Элементы.АдресКартинки.Масштабировать = Истина;

КонецПроцедуры

&НаКлиенте

Процедура ЗагрузитьКартинкуНаСервере()

ЗагрузитьКартинкуНаСервере();

КонецПроцедуры

&НаКлиенте

Процедура ЗагрузитьКартинку(Команда)

Оповещение = Новый ОписаниеОповещения("ЗагрузитьКартинкуЗавершение", ЭтотОбъект);

НачатьПомещениеФайла(Оповещение, , , Истина, УникальныйИдентификатор);

КонецПроцедуры

&НаКлиенте

Процедура ЗагрузитьКартинкуЗавершение(Результат, Адрес, ВыбранноеИмяФайла, ДополнительныеПараметры) Экспорт

Если НЕ Результат Тогда

Возврат;

КонецЕсли;

АдресКартинки = Адрес;

Модифицированность = Истина;

КонецПроцедуры

&НаСервере

Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)

Если ЭтоАдресВременногоХранилища(АдресКартинки) Тогда

ТекущийОбъект.Изображение = Новый ХранилищеЗначения(ПолучитьИзВременногоХранилища(АдресКартинки));

КонецЕсли;

КонецПроцедуры

Yandex
Возможно, вас также заинтересует
Реклама на портале
Подсказка: Вы получили ответ на свой вопрос - закройте вопрос!
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.