helpf.pro
Регистрация

План счетов

Bell
25.11.2010 22:51Прочитано: 1344
Здравствуйте
1 ВОПРОС Скажите почему нельзя просто добавить колонку ВидыСубконто в элемент формы ПланСчетовСписок (чтобы отразить видысубконто для пользователя)или может есть другой алгоритм отображения субконто?

2 ВОПРОС Скажите какой оператор в списке плана счетов определяем группу счетов, что бы ее окрасить другой цвет для удобства (Например как в справочнике ЭТОГРУППА)

Процедура ПланСчетовСписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
Колонка = ОформлениеСтроки.Ячейки;
Субконто = ДанныеСтроки.ВидыСубконто;

Если Субконто.Количество() >= 1 Тогда
Колонка.Субконто1.УстановитьТекст(?(Субконто[0].ТолькоОбороты, "(об) ", "") + Субконто[0].ВидСубконто);
КонецЕсли;

Если Субконто.Количество() >= 2 Тогда
Колонка.Субконто2.УстановитьТекст(?(Субконто[1].ТолькоОбороты, "(об) ", "") + Субконто[1].ВидСубконто);
КонецЕсли;

Если Субконто.Количество() = 3 Тогда
Колонка.Субконто3.УстановитьТекст(?(Субконто[2].ТолькоОбороты, "(об) ", "") + Субконто[2].ВидСубконто);
КонецЕсли;

Если Субконто.Количество() = 4 Тогда
Колонка.Субконто3.УстановитьТекст(?(Субконто[3].ТолькоОбороты, "(об) ", "") + Субконто[3].ВидСубконто);
КонецЕсли;


КонецПроцедуры

??????????????????????????
ПланСчетовСписок.Колонки.Добавить("ВидыСубконто", Ложь);
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
26.11.2010 10:00Ответ № 1
(0) Bell, привет
1. почему нельзя добавить ВидыСубконто? Можно добавить любую колонку и прописать что отображать! А колонок Субконто1- Субконто 3 мало что ли?
2. Понятия Группа и плана счетов нет в Типовых Бухгалтериях для выделения группы используется признак ЗапретитьИспользоватьВПроводках, как правило эти счета в проводках не участвуют
Код 1C v 8.х
  Процедура ПланСчетовСписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
Колонка = ОформлениеСтроки.Ячейки;
Субконто = ДанныеСтроки.ВидыСубконто;

// Грамотнее Количество получить 1 раз!
КолСубконто = Субконто.Количество();

Если КолСубконто >= 1 Тогда
Колонка.Субконто1.УстановитьТекст(?(Субконто[0].ТолькоОбороты, "(об) ", "") + Субконто[0].ВидСубконто);
КонецЕсли;

Если КолСубконто >= 2 Тогда
Колонка.Субконто2.УстановитьТекст(?(Субконто[1].ТолькоОбороты, "(об) ", "") + Субконто[1].ВидСубконто);
КонецЕсли;

Если КолСубконто = 3 Тогда
Колонка.Субконто3.УстановитьТекст(?(Субконто[2].ТолькоОбороты, "(об) ", "") + Субконто[2].ВидСубконто);
КонецЕсли;

Если КолСубконто = 4 Тогда
Колонка.Субконто3.УстановитьТекст(?(Субконто[3].ТолькоОбороты, "(об) ", "") + Субконто[3].ВидСубконто);
КонецЕсли;

Если ДанныеСтроки.ЗапретитьИспользоватьВПроводках Тогда
ОформлениеСтроки.ЦветФона = WebЦвета.СветлоЖелтый;
КонецЕсли;
КонецПроцедуры


Если не хочешь делать так, то используй Родитель, у Групповых счетов он пустой! т.е. что-то типо:
Код 1C v 8.х
  Если ДанныеСтроки.Родитель.ПустаяСсылка() Тогда
ОформлениеСтроки.ЦветФона = WebЦвета.СветлоЖелтый;
КонецЕсли;
Bell
26.11.2010 16:52Ответ № 2
Спасибо за разъяснение
Подсказка: Для редактирования своего ответа щелкните по значку (справа)
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.