helpf.pro
Регистрация

Вывод сообщения в отчете

rom-x
04.12.2010 18:19Прочитано: 1495
Здравствуйте! Помогите пожалуйста разобраться.
Пример взят из книги 1С Предприятие - эффективное программирование.(Усиков)(2004), реализую его в 1С: Предприятие 8.2 Версия для обучения программированию.
Итак нужно чтобы при выборе какого либо переключателя и нажатию кнопки вывести выводилось сообщение согласно листингу.
Не могу разобраться, где узнать или вывести номера порядка обхода, а также найти, где для кнопки Вывести(имя команды Сформировать) изменить название процедуры, вызываемой по нажатию кнопки на Вывести ().
Так же не пойму как связать прееключатели и код программы, чтобы все работало.
title
Код 1C v 8.2 УП
 Процедура Вывести ()
Если способ = 1 Тогда
Предупреждение ("Hello World!");
ИначеЕсли способ = 2 Тогда
Сообщить ("Hello World!", "!!!");
Иначе
Предупреждение ("Выберите, пожалуйста, способ "+
"выдачи приветствия.");
КонецЕсли;
КонецПроцедуры
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
04.12.2010 19:04Ответ № 1
(0) rom-x, в свойствах радиокнопок у одной ставишь признак первая и задаешь данные - Способ, далее указаваешь значение = 1 и второй ставишь значение 2
Название процедуры тоже меняется в свойствах!
rom-x
04.12.2010 19:23Ответ № 2
(1) E_Migachev,
не понял в свойствай кнопок Вывести и закрыть или же в свойствах реквизита?
Вот свойства кпопки Вывести
title
а вот список выбора реквизита:
title
Где мне задать данные Способ, и указывать значения?
Так же не могу найти где поменять название процедуры?
E_Migachev
04.12.2010 20:15Ответ № 3
а - это ты делаешь через Управляемое приложение ), а я тебе говорил как в обычном варианте! Управляемого под рукой нет *09, а так не помню *03
rom-x
04.12.2010 20:54Ответ № 4
(3) E_Migachev,
в любом случае спасибо!

все таки хотелось, бы узнать ответы на свои вопросы.
rzabolotin
07.12.2010 07:19Ответ № 5
Процедура Команда1(Команда)
Если Реквизит1 = 1 Тогда
Сообщить(Реквизит1);
Иначе
Предупреждение(Реквизит1);
КонецЕсли;

КонецПроцедуры
rzabolotin
07.12.2010 07:21Ответ № 6
вот пример: Скачивать файлы может только зарегистрированный пользователь!
rzabolotin
07.12.2010 07:32Ответ № 7
Интересно, зачем менять название процедуры?
rom-x
07.12.2010 08:47Ответ № 8
(6) rzabolotin,
все гениальное просто, спасибо! в книге так написано было, но в принципе незачем
rom-x
02.11.2011 00:05Ответ № 9
Вопрос закрыт!
Подсказка: Для выделения Кода используйте (в редакторе).
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.