helpf.pro
Регистрация

Цены номенклатуры 1С7.7:ТиС 9.2

bugor666
10.12.2010 10:08Прочитано: 4047
Добрый день! Возник вопрос по 1с7, в которой я пока дуб. Нужно в табличный документ вывести список номенклатуры, с закупочными и розничными ценами.
Пока написал вот это:
Код 1C v 7.x
 Процедура Сформировать()
Перем таб;
таб=СоздатьОбъект("Таблица");
спр=СоздатьОбъект("Справочник.Номенклатура");
ц=СоздатьОбъект("Справочник.Цены");
спр.ВыбратьЭлементы();
Пока спр.ПолучитьЭлемент()=1 Цикл
Наименование=спр;
ц.ВыбратьЭлементы();
ц.ИспользоватьВладельца(спр);
Пока ц.ПолучитьЭлемент()=1 Цикл
Цена=ц.ПолучитьАтрибут("Цена");
КонецЦикла;
таб.ВывестиСекцию("эл");
КонецЦикла;
Таб.Опции(0,0,1,1);
Таб.ТолькоПросмотр(1);
таб.Показать();
Сообщить("Всё!");

КонецПроцедуры

В табличный документ выводит наименования, но цены ни в какую не выходят...
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
10.12.2010 10:30Ответ № 1
реквизит Цена периодический, задай период получения значения и все будет ок )
bugor666
10.12.2010 10:37Ответ № 2
...об этом не подумал. А каким методом это можно сделать? В методе ПолучитьАтрибут() допустим только один параметр. ВыбратьЭлементы() тоже не требует периода...
Просмотрел синтаксис помощник, ничего в глаза не бросилось... *11
E_Migachev
10.12.2010 10:57Ответ № 3
вот v7: Периодические реквизиты справочника, только 1С v7
bugor666
10.12.2010 11:00Ответ № 4
Благодарю!
Подсказка: Щелникни по Имени пользователя напротив ответа, и тем самым покажешь, что сообщение адресовано ему.
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.