helpf.pro
Регистрация

Подключение весов в УПП 1.3.6.1

hanio
13.12.2010 14:07Прочитано: 4753
Подскажите как подключать весы у меня код вот такой
// Инициализация весовой
ок=1;
Если ЗагрузитьВнешнююКомпоненту(КаталогПрограммы()+"vk_rs232")=0 Тогда
Сообщить("Внешняя компонента не была загружена!","!");
Иначе
rs232=СоздатьОбъект("AddIn.vk_rs232");
КонецЕсли;

ИмяПорта=""+Константа.ComPort;

Сообщить("Константа.ComPort: "+ИмяПорта);
Сообщить("При считывании кода, который завершается символами #13#10, здесь должны появляться считанные строки.");

//Начинаем слушать порт
rs232.ОткрытьПорт(ИмяПорта);

Собственно ругается на
{МодульОбычногоПриложения(100,7)}: Обращение к процедуре как к функции (ЗагрузитьВнешнююКомпоненту)
Если <<?>>ЗагрузитьВнешнююКомпоненту(КаталогПрограммы()+"vk_rs232")=0 Тогда (Проверка: Толстый клиент (обычное приложение))
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
13.12.2010 14:56Ответ № 1
(0) hanio, не так обращаешься *08
вот рабочий пример:
Код 1C v 8.2 УП
 Попытка 
ЗагрузитьВнешнююКомпоненту("scanopos.dll")
Исключение
Сообщить("Ошибка загрузки внешней компоненты!");
КонецПопытки;

Попытка
// Получить объект компоненты.
Объект = Новый("AddIn.Scanner");
Исключение
Сообщить("Не удалось создать объект внешней компоненты");
КонецПопытки;
hanio
13.12.2010 15:17Ответ № 2
Ошибка загрузки внешней компоненты!
Не удалось создать объект внешней компоненты

библиотеку порегил, файл лежит прямо в базе

что тут?
E_Migachev
13.12.2010 15:51Ответ № 3
(2) hanio, скопируй ее в каталог программы и попробуй так:
Код 1C v 8.х
 ЗагрузитьВнешнююКомпоненту(КаталогПрограммы()+"vk_rs232.dll")   
hanio
13.12.2010 15:58Ответ № 4
а входить именно на том компе к которому подключены весы?
E_Migachev
13.12.2010 16:38Ответ № 5
(4) для загрузки компоненты и получения объекта не обязательно, а для получения данных - да
hanio
13.12.2010 20:02Ответ № 6
одна баня не получается загрузить компоненту
hanio
14.12.2010 08:43Ответ № 7
ПодключитьВнешнююКомпоненту("AddIn.vk_rs232");

Попытка
// Получить объект компоненты.
Объект = Новый("AddIn.vk_rs232");
//Объект = Новый("AddIn.scanopos");
Исключение
Сообщить("Не удалось создать объект внешней компоненты");
КонецПопытки;

А так прокатит?

Ошибок не выдалось а вот работает или нет не знаю как проверить
E_Migachev
14.12.2010 09:52Ответ № 8
(7) hanio, проверить на том компе, где весы
hanio
14.12.2010 10:48Ответ № 9
А как именно проверить?
E_Migachev
14.12.2010 10:56Ответ № 10
(9) hanio, смотри документацию к компоненте!
вот у тебя же был код:
Код 1C v 8.х
 Сообщить("Константа.ComPort: "+ИмяПорта);
Сообщить("При считывании кода, который завершается символами #13#10, здесь должны появляться считанные строки.");

//Начинаем слушать порт
rs232.ОткрытьПорт(ИмяПорта);

слушай порт и получай с него данные!
hanio
15.12.2010 22:53Ответ № 11
а какой код в обработчике ожидания?

такой?

Процедура ОбработкаВнешнегоСобытия(Источник,Событие,Данные)//Предопределенная процедура 1С
//Глобальный обработчик внешнего события
Сообщить("Внешнее событие: Источник="+Источник+" Событие="+Событие+"Данные=" + Данные);
Если (Источник="vk_rs232") И (Событие="BarCodeValue") Тогда
rs232.ЗакрытьПорт();
Сп = Новый ("СписокЗначений");
Сп.ИзСтрокиСРазделителями(""""+СтрЗаменить(Данные,",",""",""")+"""");
Если Сп.РазмерСписка()=4 Тогда
Зн = СокрЛП(Сп.ПолучитьЗначение(4));
Поз = Найти(Зн," ");
Результат=Число(Лев(Зн,Поз-1));
КонецЕсли;
rs232.ОткрытьПорт("COM1");
rs232.КонецСтроки=Символ(13);
КонецЕсли;
КонецПроцедуры
hanio
16.12.2010 09:36Ответ № 12
вот мне не понятно не догоняю как отрабатывает ОбработкаВнешнегоСобытия если я его поместил в модуль формы документа то он сработает???
E_Migachev
16.12.2010 10:13Ответ № 13
(11) hanio, Похоже что нужно вешать обработчик ожидания, чтобы каждую секунду он слушал порт

А документации нет что ли?
hanio
16.12.2010 12:17Ответ № 14
какая?
E_Migachev
16.12.2010 13:34Ответ № 15
к весам документация, описание работы с драйвером и т.д.
hanio
16.12.2010 14:00Ответ № 16
американские весы мануалов нет
E_Migachev
16.12.2010 14:52Ответ № 17
но к драйверу, обязательно, должно что-то быть, на их сайте поищи
hanio
09.03.2011 21:30Ответ № 18
Вопрос закрыт!
Подсказка: Щелкнув по значку (справа от названия вопроса), вы получите список ответов на похожие вопросы!
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.