helpf.pro
Регистрация

Формирование таблиц значений внутри запроса - не догоняю как

IKSparrow
17.12.2010 10:00Прочитано: 1759
Справочник контрагентов. У него подчинённый справочник договоров. Надо вернуть в запросе контрагента и таблицу значений заполненную договорами контрагента по определённым условиям. Чего то синтаксис не соображу такого запроса.
Yandex
Возможно, вас также заинтересует
Реклама на портале
bugor666
17.12.2010 10:36Ответ № 1
Какая конфигурация? Версия?
IKSparrow
17.12.2010 10:36Ответ № 2
УТ 8.1
Да в принципе, это на любой конфе можно смоделировать где есть контрагенты и подчинённый им справочник договора
bugor666
17.12.2010 10:40Ответ № 3
...синтаксис разный *13 ... щас попробую разобраться.
bugor666
17.12.2010 10:54Ответ № 4
(2) IKSparrow, вот что у меня получилось при помощи конструктора запросов. Владелец - это ссылка на контрагента.

Код 1C v 8.х
 Процедура ЗапросКонтрагента() Экспорт
"ВЫБРАТЬ
| ДоговорыКонтрагентов.Владелец КАК Владелец,
| КОЛИЧЕСТВО(РАЗЛИЧНЫЕ ДоговорыКонтрагентов.Наименование) КАК Наименование,
| КОЛИЧЕСТВО(РАЗЛИЧНЫЕ ДоговорыКонтрагентов.Организация) КАК Организация
|ИЗ
| Справочник.ДоговорыКонтрагентов КАК ДоговорыКонтрагентов
|
|СГРУППИРОВАТЬ ПО
| ДоговорыКонтрагентов.Владелец
|
|УПОРЯДОЧИТЬ ПО
| Владелец"
КонецПроцедуры
IKSparrow
17.12.2010 11:00Ответ № 5
(4) Анефига )
Речь идёт про вложенные таблицы в списке полей выборки.
Пример:
Код SQL
 
ВЫБРАТЬ
Документ.РасходнаяНакладная.Ссылка,
Документ.РасходнаяНакладная.Состав.(Номенклатура КАК Товар,Количество)


По аналогии хочу получить договора контрагентов в виде такой вложенной таблицы.
IKSparrow
17.12.2010 11:09Ответ № 6
Так, судя по интернету, ЖКК и прочему не умеет так делать 1С. Вернее умеет, но только для табличных частей тех объектов, к которым производится выборка.
bugor666
17.12.2010 11:18Ответ № 7
Вот с табличными частями проблем точно нет. Причем как в запросе, так и без запросов. А как вложенные таблицы сделать?... Может Мигачев подскажет?...
IKSparrow
17.12.2010 11:26Ответ № 8
(7) Будем надеяться )
bugor666
17.12.2010 14:43Ответ № 9
Может это на мысль натолкнет.

Код 1C v 8.х
 			//Делаем выборку по Владельцу. То есть по Номенклатуре.
Выборка = Справочники.ЕдиницыИзмерения.Выбрать(,Номен);
Пока Выборка.Следующий() Цикл
//Если нашли совпадение по слову "шт" - заносим ее в таб.часть
Если Выборка.Наименование = ТЗ.Получить(новСтрока-1).Получить(5) Тогда
новСтр.ЕдиницаИзмерения = Выборка.Ссылка;
КонецЕсли;
КонецЦикла;
//Если не нашли - контрольный выстрел
Если ЗначениеЗаполнено(новСтр.ЕдиницаИзмерения) = Ложь Тогда
новСтр.ЕдиницаИзмерения = Выборка.Ссылка;
КонецЕсли;
E_Migachev
17.12.2010 15:44Ответ № 10
(7) (8) это возможно только для Табличных частей! в других случаях это невозможно *09
Если очень нужно, то с помощью нескольких строк кода, такую ТЗ реально получить
IKSparrow
17.12.2010 16:15Ответ № 11
(10) Да как с кодом сделать это я представляю. Я думал, может с помощью запроса можно было сделать... Эх....
Подсказка: Вы можете добавить любую страничку в Избранное щелкнув по значку
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.