helpf.pro
Регистрация

Работа с докуметами

Bell
06.01.2011 16:36Прочитано: 1739
Здравствуйет
Хочу сделать реестр документов
Сделел отбор документа Платежное поручение,
А как сделать сразу вы бор повсем докуметам за период
Код
Процедура КоманднаяПанель1кнСформировать(Кнопка)
ТЗ.Очистить();
Док=Документы.ПлатежноеПоручение.Выбрать(НачПериода,КонПериода);

Пока Док.Следующий()Цикл

НВС=ТЗ.Добавить();// НВС=НоваяСтрока
НВС.Установить(0, "");
НВС.Установить(1, Док.ПометкаУдаления);
НВС.Установить(2, Док.Проведен);
НВС.Установить(3, Док.Дата);
НВС.Установить(4, Док.Номер);
НВС.Установить(5, Док.Ссылка);

КонецЦикла;
КонецПроцедуры
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
07.01.2011 11:50Ответ № 1
(0) Bell, cмотри v8: Выборка, перебор документов
Bell
09.01.2011 10:32Ответ № 2
Я может быть корретно поставил вопрос
Док=Документы.ПлатежноеПоручение.Выбрать(НачПериода,КонПериода);
Данный алгоритм выбирает только Платежные поручения за период, а мне
требуется чтобы выбрал ВСЕ документы с базы "перебором документов" Платежные поручения. выписки авансовые отчеты и т.д. Запросом я это могу это сделать, но для учебы надо и знать таким способом .
E_Migachev
09.01.2011 23:08Ответ № 3
(2) Bell, нужно через метаданные перебрать все документы конфигурации и в выборке выбирать документы, примерно так:
Код 1C v 8.х
 Для Каждого ТекДокум Из Метаданные.Документы Цикл
Док=Документы[ТекДокум].Выбрать(НачПериода,КонПериода);
Пока Док.Следующий()Цикл
НВС=ТЗ.Добавить();// НВС=НоваяСтрока
НВС.Установить(0, "");
НВС.Установить(1, Док.ПометкаУдаления);
НВС.Установить(2, Док.Проведен);
НВС.Установить(3, Док.Дата);
НВС.Установить(4, Док.Номер);
НВС.Установить(5, Док.Ссылка);
КонецЦикла;
КонецЦикла;
Подсказка: Вы можете приложить к ответу файл или изображение щелкнув по значку или в редакторе.
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.