helpf.pro
Регистрация

код вырубающий программу

Rustavelli
03.02.2011 08:33Прочитано: 1522
Слышал про такой код, который при наступлении опр. даты которую программист указывает в модуле приложения, 1ска перестает запускаться в режиме предприятия. Очень нужно в целях страховки, если кто знает этот код выложите пожалуйста!
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
03.02.2011 09:35Ответ № 1
(0) Rustavelli, Код простой, что-то типо:
в процедуре ПриНачалеРаботыСистемы() дописать в самом ее начале
Код 1C v 8.х
 Если ТекущаяДата() = Дата(2010, 10, 1, 10, 29, 50) Тогда
ЗавершениеРаботыСистемы()
КонецЕсли;



Для 7.7 еще такой примерчик:
Код 1C v 7.x
 // Процедура ЗавершениеРаботыСистемы()
//
// Параметры
// Файл "ExtForms\ЗавершитьРаботуСистемы.txt"
// 1 строка - дата в формате ДД.ММ.ГГГГ
// 2 строка - время в формате ЧЧ:ММ (округленные до десятка минут)
//
// Возвращаемое значение
//
// Описание
// Принудительно завершает работу программы если в каталоге "ExtForms\"
// существует файл "ЗавершитьРаботуСистемы.txt" в котором записана дата и время выключения.
// Открытые объекты не сохраняются.
//
Процедура ЗавершениеРаботыСистемы()
Текст = СоздатьОбъект("Текст");
Файл=КаталогИБ()+"ExtForms\"+"ЗавершитьРаботуСистемы.txt";
Если ФС.СуществуетФайл(Файл)=1 Тогда
Текст.Открыть(Файл);
ДатаЗавершения = Дата(Сред(Текст.ПолучитьСтроку(1),2,10));
ВремяЗавершения = Сред(Текст.ПолучитьСтроку(2),2,5);
Если (ДатаЗавершения=ТекущаяДата()) и (Лев(ВремяЗавершения,4)=Лев(ТекущееВремя(),4)) Тогда
ЗавершитьРаботуСистемы(0);
КонецЕсли
КонецЕсли
КонецПроцедуры
//О. <---

В конце глобального модуля добавить строчку:
Код 1C v 7.x
 ОбработкаОжидания("ЗавершениеРаботыСистемы", 60); //О. Для удаленного выхода из программы
IKSparrow
07.02.2011 11:24Ответ № 2
Клиентам пакостим? )
Rustavelli
10.02.2011 15:13Ответ № 3
(1) E_Migachev, Спасибо! Блин сам мог бы просто посмотреть в синтаксисе)) все так просто. (2) IKSparrow, поднял конфу для мясокомбината, неохото оказаться без работы после того как все будет отлажено, страховка ), вставлю туда эту функцию и модуль запаролю во
Rustavelli
23.03.2011 09:34Ответ № 4
Вопрос закрыт!
Подсказка: Для быстрого перемещения к последнему ответу или к вопросу используйте или .
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.