helpf.pro
Регистрация

параметры страницы долго открываются

aleksprg
05.02.2011 17:48Прочитано: 3475
В торговле 8.1 конфигурация 10.13.3 на одном компьютере параметры страницы долго открываются и настройки параметров страницы не сохраняются. В чем может быть причина ?
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
06.02.2011 20:33Ответ № 1
(0) aleksprg, варианты решения проблемы следующие:
1. Обновить драйвер принтера
2. Имя принтера должно быть не больше 8 символов
3. Удалить пользовательские настройки:
для 8.х папка: C:/Documents and Settings/User/Application Data/1C/1Cv81/<Идентификатор информационной базы>/<Идентификатор пользователя>/
для 7.7 ключ в реестре: HKEY_CURRENT_USER\Software\1C\1Cv7\7.7\НазваниеБазы\V7\ИмяПользователя\Moxel

Отпишись потом - что да как у тебя получилось!
E_Migachev
06.02.2011 20:36Ответ № 2
набрел на интересное решение для 7.7:
Предложеное решение реализует следующее: удаляет в реестре упоминание о текущем принтере, сделанное 1С. В момент вызова Напечатать(0) 1С обращается в реестр за названием принтера, естественно его там не находит и иницирует запрос к Windows, которая в ответ выполняет "HTTP Printer Connection Through Web Browser".
Принтеры, доступ к которым осуществляется по IPP создаются Windows по запросу на время печати, после чего удаляются.
Вероятно, 1С рассчитана на работу с "RPC Printer Connection" и не учитывает всех особенностей работы "HTTP Printer Connection Through Web Browser".

Возможная альтернатива - использование Напечатать(1). В этом режиме 1С выдаст оконо параметров печати и, естественно, выполнит нужный запрос.

Код 1C v 7.x
 //Сохранение названий баз
Ключ="HKEY_CURRENT_USER\Software\1C\1Cv7\7.7\Titles";
ИмяКаталога=СокрЛП(КаталогПользователя());
ИмяБазы=СокрЛП(каталогИБ());
Если прав(ИмяКаталога,1)<>"\" Тогда ИмяКаталога=ИмяКаталога+"\" КонецЕсли;
Если прав(ИмяБазы,1)<>"\" Тогда ИмяБазы=ИмяБазы+"\" КонецЕсли;
ИмяБазыСтр=Симв(34)+СтрЗаменить(ИмяБазы,"\","\\")+Симв(34);
ИмяФ=ИмяПользователя()+".reg";
КомандаСистемы("Regedit /ea "+Симв(34)+ИмяКаталога+ИмяФ+Симв(34)+" "+Симв(34)+Ключ+Симв(34));
Текст=СоздатьОбъект("Текст");
Текст.КодоваяСтраница(0);
Текст.Открыть(ИмяКаталога+ИмяФ);

//Поиск названия текущей базы в созданном файле с названиями баз
Стр="";
Для сч=1 по Текст.КоличествоСтрок() Цикл
Стр=СокрЛП(Текст.ПолучитьСтроку(сч));
Если Найти(Стр,ИмяБазыСтр)<>0 Тогда
прервать;
КонецЕсли;
КонецЦикла;

//Выборка названия базы
Стр = СтрЗаменить(Сред(Стр,Найти(Стр,"=")+2,СтрДлина(Стр)-Найти(Стр,"=")-2),"\","");

//Удаление ключа реестра
РеестрКлюч = СоздатьОбъект("Текст");
РеестрКлюч.ДобавитьСтроку("REGEDIT4");
РеестрКлюч.ДобавитьСтроку("[HKEY_CURRENT_USER\Software\1C\1Cv7\7.7\"+Стр+"\V7\"+ИмяПользователя()+"\Moxel\Default]");
РеестрКлюч.ДобавитьСтроку(Симв("34")+"DefaultPrinter"+Симв("34")+" =-");
РеестрКлюч.Записать(ИмяКаталога+ИмяПользователя()+".reg");
РеестрКлюч = "";
КомандаСистемы("regedit.exe -s "+ИмяКаталога+ИмяПользователя()+".reg");
КомандаСистемы("del "+ИмяКаталога+ИмяПользователя()+".reg");
aleksprg
08.02.2011 10:54Ответ № 3
Удалял пользовательские настройки в торговле не помогло,потом посмотрел в папке принтеры было много подключенных через сеть принтеров.Они добавлялись как авто.Удалил их все кроме двух.Удалил ненужные драйвера меню файл свойство сервера. Ну и потом проверил параметры страницы. Теперь стали быстро открываться.
Подсказка: Для быстрого поиска ответов - используйте 'Поиск'
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.