helpf.pro
Регистрация

Help!!!! Из конфигурации исчезает код....

FeliceYa
01.03.2011 19:12Прочитано: 1137
Платформа 8.1.15, но впервые этот глюк был замечен ещё на 8.1.12.... База работает в серверном варианте: СУБД MS SQL Server 2000 8.0.2039 (СУБД не менялась).
Ситуация такая: Однажды один из мох пользователей жалуется, что неправильно считается сумма документа.... Пробую сама - действительно неправильно. Вхожу под собой (с правами администратора) - тоже самое. Запускаю конфигуратор, смотрю пошагово как считается сумма документа.... И обнаруживаю, что срока в которой должна проводиться часть расчётов ОТСУТСТВУЕТ! *18 Захожу с другого компа...., с третьего - всё на месте, и считает правильно.... *08 Возвращаюсь за комп с глюком. Вхожу в Винду под админом - строчка кода на месте в конфигураторе, и правильно считается в пользовательском режиме. *01 Из ситуации вышла тем, что создала нового пользователя Windows - всё стало работать как должно.
Спустя пол года на другом компе исчезла часть привязок в форме элемента справочника. *03
Ещё спустя месяц, уже на третьем компьютере, исчезла часть текста запроса в отчёте.... *15

Может кто знает из-за чего может такое быть? И как это можно вылечить????
Yandex
Возможно, вас также заинтересует
Реклама на портале
FeliceYa
01.03.2011 22:55Ответ № 1
Примерно так выглядят различия в тексте одного и того же запроса (прописанного в коде)
Скачивать файлы может только зарегистрированный пользователь!
Слева - как должно быть. Справа.... даже не знаю как это назвать.... *01
E_Migachev
02.03.2011 10:33Ответ № 2
(1) FeliceYa, мистика какая-то ) так не бывает!
с привязками бывает, нужно в папке пользователя удалить все из папки 1С!
Но чтобы код был разным - такое встречаю впервые *09
FeliceYa
02.03.2011 12:09Ответ № 3
(2) E_Migachev, абсолютно согласна - так не бывает, но в моей подопечной базе это второй случай (не считая случая с пивязками) *01
E_Migachev
02.03.2011 12:26Ответ № 4
(3) FeliceYa, может все же базы разные? *09
FeliceYa
02.03.2011 15:48Ответ № 5
(4) E_Migachev, База точно одна *07
А вот удаление папки C:\Documents and Settings\<user_Windows>\Application Data\1C помогло *13

Как бороться с подобным глюком понятно, а вот из-за чего он может появляться????.... *08
E_Migachev
02.03.2011 17:32Ответ № 6
(5) FeliceYa, бывает из-за неправильного выключения компов и т.д
когда большая сеть - из-за не грамотной настройки профилей пользователей
FeliceYa
02.03.2011 19:06Ответ № 7
(6) E_Migachev, Неправильное выключение - это могло быть, у нас периодически может отключаться электричество.... А на какие параметры нужно обратить внимание что быть уверенной, что прифили пользователей настроены правильно?
E_Migachev
03.03.2011 09:36Ответ № 8
(7) FeliceYa, по настройке профилей - нужно спросить хорошего сисадмина, я в этом не особо силен *08, в вашем случае похоже что на отключение света, ставьте UPSы
FeliceYa
03.03.2011 14:00Ответ № 9
(8) E_Migachev, Спасибо )
Подсказка: Для быстрого поиска ответов - используйте 'Поиск'
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.