helpf.pro
Регистрация

Штатный перенос из ЗИК в ЗУП: Непонятная ошибка

IKSparrow
25.03.2010 21:53Прочитано: 8026
Ошибка записи объекта
ТипОбъекта = Документ ссылка: Перенос данных
Объект = Перенос данных УОЗ от 25.03.2010 0:00:00
ОписаниеОшибки = Ошибка при вызове метода контекста (Записать): Запись с такими ключевыми полями существует! : Иванов Иван Иванович : Цех №2 (р. Коми) Управления по восстановлению скважин : : : 01.02.2005 0:00:00 (Регистр сведений: Учет основного заработка сотрудников организации в регламентированном учете; Номер строки: 5)
ПозицияМодуля = Обработка.УниверсальныйОбменДаннымиXML(4754)
КодСообщения = 26

Появляется такая вот ошибка при работе штатного переноса ЗИК=>ЗУП. Проблема в том, что в ЗИКе не соображаю, а проблема явно в чём то там. Куда и что копать?
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
25.03.2010 22:05Ответ № 1
проблема в том что в регистре сведений Учет основного заработка сотрудников организации в регламентированном учете уже есть запись по Иванову от 1.02.05 и вторую создать он не даст

Нужно смотреть в зике, где второй раз это проходит или при загрузке поставить Не проводить документы, а потом проводя вручную отловишь задвоение.
IKSparrow
26.03.2010 08:41Ответ № 2
Выяснилось, что в ЗИКе за один и тот же период для одного и того же сотра основной заработок несколько раз начислен. Но как его отловить...? Каким "волшебным" отчётом? )
E_Migachev
26.03.2010 08:55Ответ № 3
Это должны были отслеживать бухгалтера при формировании расчетной ведомости
E_Migachev
26.03.2010 09:17Ответ № 4
отчета подходящего нет, только самому писать перебор журнала расчета по каждому сотруднику и смотреть начисления *09
alina
26.03.2010 18:23Ответ № 5
У меня тоже была такая же проблема. Решила ее так - есть обработка для 7.7 "Мягкая смена периода".
1.Открываю 7.7.Применяю обработку на самую раннюю дату(чтобы менять данные во всех нужных периодах).
2.Вручную удаляю записи, которые вызывают задвоение(в вашем случае надо поискать это отражение заработка в регл учете ), исправить-изменить-удалить - по ситуации.
3.Осуществляю перенос ЗиК- ЗУП.

Вот вам эта обработка (она для ЗиК 7.7)Скачивать файлы может только зарегистрированный пользователь!
IKSparrow
29.03.2010 13:42Ответ № 6
Так, всё очень плохо ) Сели с расчётчиком и посмотрели период, в котором проблема - в (0) указано, что "01.02.2005 0:00:00 (Регистр сведений: Учет основного заработка сотрудников организации в регламентированном учете;" я так понял, что в феврале эти расчёты и задвоились. Но там ничего подобного нет. На всякий случай прошерстили и 2004 год и 2005. Не задваивается. Кроме того, не ясен вот какой момент - я так понимаю, что с точки зрения процедуры загрузки в восьмёрке этот расчёт был назначен Иванову в контексте его работы в подразделении "Цех №2 (р. Коми) Управления по восстановлению скважин" как это указано в (0). Но Иванов никогда не работал в этом подразделении. Он вообще из администрации. И в командировки он тоже никогда не ездил. В общем, расчётчик в недоумении, ну а я в шоке. Непонятно где искать источник ошибки. Есть какая-нибудь процедура тотального перерасчёта всех записей о расчётах в ЗИКе?

Алина, спасибо, сейчас скачаю обработку посмотрю каким будет результат.
IKSparrow
29.03.2010 13:54Ответ № 7
Ура! Я нашёл подозрительное место! *06
Дело всё в документе "Кадровое перемещение"
В ЗИКе он имеет следующий вид:
Иванов Иван Иванович
Подразделение - Администрация

А в ЗУПе перегруженный документ имеет такой вид:
Иванов иван Иванович
Подразделение - Цех №2 (р. Коми) Управления по восстановлению скважин

Неправильно подцепилось подразделение. Но! Приказ о приеме на работу в организации по подразделениям в ЗУПе оформлен правильно! Там подразделение "Администрация". С чего такой глюк может быть? Кстати, Цех№2 это обособленное подразделение. С этим может быть что-нибудь связано?
E_Migachev
29.03.2010 14:32Ответ № 8
тебе нужно запускать перепроведение доков в ЗУПЕ и смотреть на каком документе вылетит ошибка, далее ишесь этот докум в ЗИКе и далее по ходу что-то правишь в ЗУПе.

Что качается тотального перерасчёта всех записей о расчётах в ЗИКе - есть такие обработки в интернете...

Неправильно подтягивает подразделение - нужно смотреть код, как грузит, что создает...
Может все-таки есть не проведенный документ с такими данными?
IKSparrow
29.03.2010 21:27Ответ № 9
В общем, дело оказалось не в документах и не в расчётах. Фигня в переносе данных об организациях и подразделениях.
Абсолютно по неясной причине подразделения переносятся абы как. Категорически не понимаю проблемы переноса. Например из 30 обособленных подразделений в справочник организаций попадает всего-лишь 6 подразделений. Причём, одним из них подменяется организация. Отсюда и все беды. Почему штатная схема не работает как надо - не понимаю.
E_Migachev
29.03.2010 22:22Ответ № 10
сложно сказать, тут только нужно садиться и через отладчик прогонять *08
Проще написать свою перегрузку.

Попробуй вот эту обработку alexerа Скачивать файлы может только зарегистрированный пользователь! для 8.1 и 8.2
Простенькая обработка рассчитана на тех, кто хоть как-то программирует в 1С. Суть обработки заключается в том, что выбрав необходимый вид документа в семерке и вид документа в восьмерке, текстовое поле заполняется процедурой для загрузки данных. После правки этого текста модуля и нажатия кнопки "Выполнить", произойдет создание документов. Реквизиты в модуль можно перетаскивать методом Drag & D_rop.
Ее можно также использовать как помощник для написания процедур модуля при загрузке документов.
Есть возможность сохранения настроек, с помощью "Файл\Сохранить". Настройки сохраняются в папке C:\Temp1C\.

title
IKSparrow
30.03.2010 12:06Ответ № 11
Евгений, спасибо за помощь. И писать обработки свои или использовать чужие - это конечно здорово, но судя по всему закралась в систему какая-то методическая ошибка. И если все данные переносить в новую базу то и ошибка, стало быть, перенесётся. На обычной демо-базе перенос работает. На моей базе перенос работает коряво. И уже есть несколько версий откуда ноги растут. У нас огромнейший бардак в справочнике подразделений в ЗИКе. Видимо по этой причине информация так коряво и переносится.
Кстати, кто-нибудь знает - КПП у обособленного подразделения может быть равным КПП головной организации? Или этот код столь же уникален как и ИНН?
IKSparrow
30.03.2010 14:33Ответ № 12
Так, ну я надеюсь, я вам всем ещё не надоел со своей эпопей, которая продолжается. Вдруг мой опыт кому-нибудь пригодится. В общем, как я и подозревал - неаккуратность в ведении справочника "Подразделения" в ЗИКе аукается при переносе данных в ЗУП. В чём заключается эта неаккуратность:
1) У обособленных подразделений не указан реквизит КПП либо он совпадает с КПП головной организации
2) У тех же подразделений не забит адрес
3) У них же не указаны руководители, бухгалтера.
Стоило мне сделать выборочную проверку и поправить эти данные у нескольких подразделений, которые особо часто мелькают в ошибках при переносе, как тут же документы по ним встали на своё место. Из чего я делаю законный логический вывод, что проблема была именно в этом. Сейчас на всякий случай ещё сделаю ряд перекрёстных проверок, несколько пробных выгрузок и завтра пойду ругаться с бухгалтерами.

p.s.> Ёлки-палки, да я с этим ЗУПом/ЗИКом стану зверским методистом *06
E_Migachev
01.04.2010 09:03Ответ № 13
*09 Так всегда, при переносе данных вылезают все ошибки!
Хорошо если ответственный бухгалтер и он знает все ошибки, а в твоем случае, похоже, бухгалтера не заморачивались с правильным ведением учета.
Хотя позиция многих бухгалтеров такова - Что не выводит 1С, то Выведем при помощи Excel )
IKSparrow
06.04.2010 10:03Ответ № 14
Так, ну в общем и в целом проблему решил. Лёгкая модернизация существующей обработки, ликвидация глюков в ЗИКе по части некорректно заполненного справочника Подразделений, перепроведение документов (Алина, спасибо за обработку смены периода!).
E_Migachev
07.04.2010 10:50Ответ № 15
Поздравляю с завершением эпопеи )
IKSparrow
26.04.2010 10:07Ответ № 16
Кстати, хотелось бы дополнить эту тему описанием ещё одной ситуации. На днях пришлось мне делать перенос данных из ЗИКа в ЗУП (для набивки руки полезно, да и опыту набраться - тоже пригодиться). И возникла у меня ошибка точь-в-точь как в первом сообщении этой темы. Однако, на этот раз справочник "Подразделения" оказался в полном порядке. Источник проблемы оказался на самом виду - практически по всем сотрудникам, оказалось дублирование записей за один и тот же период в реквизите "ШаблонПроводки". Из-за этого обработка не могла сформировать документ ввода остатков "Учёт Основного Заработка". Лишние записи этого периодического реквизита отличало то, что у них не было указано каким именно документом они были введены сотруднику. Поэтому мною был написан простенький код для чистки лишних дублей:
Код 1C v 7.x
 

ПерОб = СоздатьОбъект("Периодический");
СпрСотрудники = СоздатьОбъект("Справочник.Сотрудники");
// Делаем выборку из справочника "Сотрудники"
СпрСотрудники.ВыбратьЭлементы(0);
Пока СпрСотрудники.ПолучитьЭлемент() = 1 Цикл
// Группы не обрабатываем
Если СпрСотрудники.ЭтоГруппа() = 1 Тогда
Продолжить;
КонецЕсли;
// Удалённых сотрудников тоже на фиг
Если СпрСотрудники.ПометкаУдаления() = 1 Тогда
Продолжить;
КонецЕсли;
// Сотрудников у которых нет периодики по реквизиту "ШаблонПроводки" тоже в лес
ПерОб.ИспользоватьОбъект("ШаблонПроводки",СпрСотрудники.ТекущийЭлемент());
Если ПерОб.ВыбратьЗначения(НачДата,КонДата) = 0 Тогда
Продолжить;
КонецЕсли;
// Перебираем историю реквизита "ШаблонПроводки"
Пока ПерОб.ПолучитьЗначение() = 1 Цикл
Если ПустоеЗначение(ПерОб.ТекущийДокумент()) = 1 Тогда
// Если нет документа, которым вводился этот реквизит, тогда удаляем значение
// и сообщаем у кого удалили
Если ПерОб.Удалить() = 1 Тогда
Сообщить(СпрСотрудники.ТекущийЭлемент());
Иначе
// А если не получилось удалить, то сообщаем у кого не удалилось историческое значение
// Вообще такого быть не должно, но мало ли
Сообщить(СпрСотрудники.ТекущийЭлемент()+" не удалено!");
КонецЕсли;
КонецЕсли;
КонецЦикла;
КонецЦикла;

Подсказка: Для быстрого поиска ответов - используйте 'Поиск'
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.