helpf.pro
Регистрация

поиск позиции сайта в html коде

curys
19.05.2011 09:33Прочитано: 3022
Доброго времени суток.
Стоит задача получить позицию сайта в яндексе.
Запрос к яндексу я написал и сохраняю его в файл, далее открываю его как текстовый документ, а далее мне необходимо найти позицию нужного мне сайта в этом текстовом документе, т.е. по коду HTML.

Подскажите как лучше осуществить поиск этой позиции?
Yandex
Возможно, вас также заинтересует
Реклама на портале
Mokey
19.05.2011 11:38Ответ № 1
Можно просто функцией Найти(), если известно назване сайта
curys
20.05.2011 10:23Ответ № 2
(1) Mokey, сначала определяется позиция,
Вот этой строкой: <b class=b-serp-item__number>1</b>
а потом только идет информация о сайте
E_Migachev
20.05.2011 10:44Ответ № 3
(2) curys, и в чем проблема, находи в тексте по названию или имени сайта и далее получай что тебе надо *13
curys
23.05.2011 14:15Ответ № 4
а можно примерчик, а то до меня не доходит=(
E_Migachev
23.05.2011 15:01Ответ № 5
Код 1C v 8.х
  //Выбор файла
Режим = РежимДиалогаВыбораФайла.Открытие;
ДиалогОткрытияФайла = Новый ДиалогВыбораФайла(Режим);
ДиалогОткрытияФайла.ПолноеИмяФайла = "";
Фильтр = "Текст(*.txt)|*.txt";
ДиалогОткрытияФайла.Фильтр = Фильтр;
ДиалогОткрытияФайла.МножественныйВыбор = Ложь;
ДиалогОткрытияФайла.Заголовок = "Выберите файл для загрузки";
Если ДиалогОткрытияФайла.Выбрать() Тогда
ПутьКФайлу = ДиалогОткрытияФайла.ПолноеИмяФайла;
КонецЕсли;

текдок=Новый ТекстовыйДокумент;
текдок.Прочитать(ПутьКФайлу);
Для Ном=1 по текдок.КоличествоСтрок() цикл
//Получим строку Ном
Стр = текдок.ПолучитьСтроку(Ном);
//Теперь ищем в строке название сайта
Если Найти(Стр, "www.sait.ru")>0 Тогда
Сообщить("Нашли сайт в строке - "+Строка(Ном));
// Иначе
// Сообщить("Не нашли");
КонецЕсли;
КонецЦикла;
curys
23.05.2011 15:42Ответ № 6
СПС=)
Подсказка: Для быстрого перемещения к последнему ответу или к вопросу используйте или .
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.