helpf.pro
Регистрация

v8: Вывод состояние в цикле

SAN_BK
02.07.2011 03:33Прочитано: 2249
Подскажите пожалуйста почему когда я в цикле посылаю команду Состояние("Текст",Процент) то текст в строке состояния я вижу а прогресс бар не отображается, что я делаю не так, ведь четко сказано, что если вторым параметром передать число от 1 до 100 то будет отображен прогресс, но его как не было так и нет, что только не пробовал...
Помогите плиз...
Делал на движке 8.2
За ранее спасибо.
Изменено 02.07.11 18:42:00
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
04.07.2011 09:37Ответ № 1
(0) SAN_BK, это работает только в Управляемом Интерфейсе (появляется как отдельное окно)!

Если хочешь увидеть Индикатор процесса в строке состояния обычного приложения, то:
Код 1C v 8.х
 Процедура КнопкаВыполнитьНажатие(Кнопка)
ПР=Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
Пр.ОтображатьПроцентВывода=Истина ;
Эл=Новый ЭлементРезультатаКомпоновкиДанных;

ПР.НачатьВывод();
Для А=1 По 100 Цикл
Эл.ПроцентВывода=А;
//задержка, чтобы разглядеть
Для Б=1 По 10000 Цикл КонецЦикла;
ПР.ВывестиЭлемент(Эл);
КонецЦикла
ПР.ЗакончитьВывод();
КонецПроцедуры
SAN_BK
12.07.2011 00:45Ответ № 2
Лихо!!! Спасибо брат на досуге попробую...
Подсказка: Для быстрого поиска ответов - используйте 'Поиск'
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.