helpf.pro
Регистрация

v8: Удаление элементов справочника

Mankubus
13.07.2011 12:37Прочитано: 2872
Подскажите пожалуйста!
В справочнике создаются элементы с наименованиями "имя+номер по порядку",
как мне удалить элементы справочника с номера Х по номер Y?
Yandex
Возможно, вас также заинтересует
Реклама на портале
Marfeus
13.07.2011 13:11Ответ № 1
Выполнить("Удалить(ЭлементыФормы.Имя"+ТекНомер+")") все это в цикле
Marfeus
13.07.2011 13:25Ответ № 2
Извини за кривой пример чуть не так.
Для ч= 2 По 3 Цикл
Выполнить("ЭлементыФормы.Удалить(ЭлементыФормы.ПолеВвода"+ч+")");
КонецЦикла;
Mankubus
13.07.2011 14:10Ответ № 3
Чета не получается *16
E_Migachev
13.07.2011 14:18Ответ № 4
(2) Marfeus, нужно удалять ссылку на элемент справочника:
Как удалить все элементы справочника?
Marfeus
13.07.2011 14:56Ответ № 5
Mankubus, извини не так понял что надо
E_Migachev
13.07.2011 15:08Ответ № 6
(5) Marfeus, делаешь выборку справочника и в условии проверяешь его номер например
Код 1C v 8.х
 Выборка = Справочники.Номенклатура.ВыбратьИерархически();
Пока Выборка.Следующий() Цикл
Если Выборка.Код = "55" Тогда
Выборка.Удалить();
КонецЕсли;
КонецЦикла;
Marfeus
13.07.2011 15:16Ответ № 7
это я знаю как делать, я думал с формы элементы удалить надо было
Mankubus
13.07.2011 15:31Ответ № 8
Метод объекта не обнаружен Выборка.Удалить(); ?
Marfeus
13.07.2011 15:44Ответ № 9
выборка.Ссылка.ПолучитьОбъект().Удалить() попробуй так
Mankubus
14.07.2011 12:46Ответ № 10
Большое Спасибо!
Подсказка: Вы можете добавить любую страничку в Избранное щелкнув по значку
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.