helpf.pro
Регистрация

v8: Регистры сведений

Bell
12.08.2011 11:04Прочитано: 1953
Здравствуйте.
Расчетная база для одного пользователя.
У меня есть регистр сведений РС_Константы (периодический(день) независимый).
Измерений
в ней НЕТ (правильно ли это и какое можно подставить в данной ситуации если надо)
Ресурсы
Это различный данные для заполнения в основной печатных форм на дату

Для получения данных я воспользовался .СоздатьНаборЗаписей(), но он выдает только значения если они есть на эту дату, т.е если есть запись на 12 число он ее покажет, а на 13 число не покажет
КАК получить данные (срез последних, последнее или как то еще). Если нет измерения не знаю как.
ЕСЛИ МОЖНО , что бы это была универсальная функция (экспорт)

Процедура ЗаполнитьПериодическиеКонстанты()

НЗ = РегистрыСведений.РС_Константы.СоздатьНаборЗаписей(); // НЗ-набор записей
НЗ.Отбор.Период.Установить(Дата);
НЗ.Прочитать();

Для Каждого Запись Из НЗ Цикл

Руководитель = Запись.Руководитель;
змРуководитель = Запись.змРуководитель;
// и т.д.

КонецЦикла;

КонецПроцедуры
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
12.08.2011 11:34Ответ № 1
Юзай СрезПоследних и через Запрос
Bell
12.08.2011 15:35Ответ № 2
Сделал запрос
На форме константы элементы Руководитель,змРуководитель и т.д НЕ реквизиты константы, а поля ввода только просмотр
Показывает все значения на даты кроме одного (перед мамым первым, в консоли запроса все правильно паказывает )2 число ДА ,3 Чпсло ДА, а вот если поставить
1 число тогда НЕТ, должно быль нол или пусто, , а показывает последнее выбранное занчение,т.е. остается последнее и все

2 Что сделал не правильно

3. Как экспортировать эту процудуру


Процедура ЗаполнитьПериодическиеКонстанты()

Запрос=Новый Запрос;
Запрос.Текст=
"ВЫБРАТЬ
|*
|ИЗ
|РегистрСведений.РС_Константы.СрезПоследних(&Дата,)";

Запрос.УстановитьПараметр("Дата",КонецДня(Дата));

Результат=Запрос.Выполнить();
Выборка=Результат.Выбрать();

Пока Выборка.Следующий()Цикл

Руководитель = Выборка.Руководитель;
змРуководитель = Выборка.змРуководитель;
// и т.д около 40 значений

КонецЦикла;
E_Migachev
12.08.2011 16:41Ответ № 3
1 и 2 - вообще не понял что надо *09
3
Код 1C v 8.х
 Процедура ЗаполнитьПериодическиеКонстанты() Экспорт   
Bell
12.08.2011 16:55Ответ № 4
В константах есть реквизит Дата на какую дату показывать значения периодических констант из регистра сведений
09.08.11 Пусто
10.08.11 Иванов Показыват Иванов Так и надо
11.08.11 Иванов Показыват Петров Так и надо
12.08.11 Иванов Показыват Сидоров Так и надо
При смене даты допустим с 12.08.11 (любая дата ) на 09.08.11 (пустой занчение) должно показать пустые значения у нас же нет никаких значений на эту дату, а показывает на 12.08.11 и т.д. Если последнюю дату мы просмотрели 10.08.11 останется она же.
Как в запросе при смене данты перед заполнением смирать придыдущие занчения, Стерил предыдущее, запросили следующее , если оно 0 тогда все будет пустое
Bell
12.08.2011 16:56Ответ № 5
ИЗВИНЯЮСЬ ВОТ ТАК НАДО
11.08.11 Петров Показыват Петров Так и надо
12.08.11 Сидоров Показыват Сидоров Так и надо
Bell
13.08.2011 09:24Ответ № 6
Все решил проблему
Спасибо
Подсказка: Вы можете добавить любую страничку в Избранное щелкнув по значку
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.