helpf.pro
Регистрация

v8.2 УП: Загрузить Список значений в Динамический спискок формы

Gnost
16.08.2011 11:28Прочитано: 2464
Добрый день, у меня есть список значений, который я формирую на сервере, мне нужно им заменить динамический список формы, как это сделать?

Код 1C v 8.2 УП
 
// Общий модуль для формирования списка

&НаСервере
Функция Промежуток(Потомок) Экспорт
СЗ = Новый СписокЗначений;
НайтиВсехПотомков(Потомок, СЗ);
Возврат СЗ;
КонецФункции

&НаСервере
Процедура НайтиВсехПотомков(Потомок, СЗ)
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
| Подразделения.Ссылка
|ИЗ
| Справочник.Подразделения КАК Подразделения
|ГДЕ
| Подразделения.Родитель = &Родитель";
Запрос.УстановитьПараметр("Родитель", Потомок);
Результат = Запрос.Выполнить().Выгрузить();
Для каждого текПотомок Из Результат Цикл
Если текПотомок.Ссылка.ЭтоГруппа = Истина Тогда
НайтиВсехПотомков(текПотомок.Ссылка, СЗ);
Иначе
НоваяСтрока = СЗ.Добавить(текПотомок.Ссылка);
КонецЕсли;
КонецЦикла;
КонецПроцедуры

// Клиент, вызывающий процедуру
&НаКлиенте
Процедура ОргПодрПриАктивизацииСтроки(Элемент)

Если Элемент.ТекущиеДанные.ЭтоГруппа = Истина Тогда
СЗ = Оборудование.Промежуток(Элемент.ТекущаяСтрока);
// Здесть я должен в РМ выгрузить полученный список значений и отобразить его в форме, как это сделать?
Иначе
ПараметрПодразделениеРМ = РМ.Параметры.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("Владелец"));
ПараметрПодразделениеРМ.Использование = Истина;
ПараметрПодразделениеРМ.Значение = Элемент.ТекущаяСтрока;
КонецЕсли;

Элементы.РМ.Обновить();

КонецПроцедуры



Изменено 16.08.11 11:47:35
Yandex
Возможно, вас также заинтересует
Реклама на портале
Gnost
17.08.2011 09:22Ответ № 1
Вопрос закрыт!
Подсказка: Щелникни по Имени пользователя напротив ответа, и тем самым покажешь, что сообщение адресовано ему.
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.