helpf.pro
Регистрация

v8: Запрос

Bell
22.08.2011 21:13Прочитано: 1193
Здравствуйте
СправочникСписок при Активизации строки хочется видеть остатки по каждому складу при движении курсора по строкам (в таблице значений тпОстаткиМХ)
Как передать параметр (скрокаАктивная)
Может подход к решению не правильный.

Процедура СправочникСписокПриАктивизацииСтроки(Элемент)

СтрокаАктивная = ЭлементыФормы.СправочникСписок.ТекущиеДанные.Ссылка;
//Сообщить("СТРОКА "+Элементыформы.СправочникСписок.ТекущаяСтрока);

Запрос = Новый
Запрос("ВЫБРАТЬ

|ТМЦОстатки.ТМЦ КАК ТМЦ,
|ТМЦОстатки.МХ КАК МХ,
|ТМЦОстатки.КоличествоОстаток КАК Количество
|ИЗ
|РегистрНакопления.ОстаткиТМЦ.Остатки(&Дата,) КАК ТМЦОстатки");// ????

Запрос.УстановитьПараметр("Дата",КонецДня(Дата) );
Запрос.УстановитьПараметр("СтрокаАктивная",СтрокаАктивная );

Выборка = Запрос.Выполнить().Выбрать();

тпОстаткиМХ.Очистить();
Пока Выборка.Следующий() Цикл

НВС=тпОстаткиМХ.Добавить();// НВС=НоваяСтрока
НВС.Установить(0,Выборка.МХ);
НВС.Установить(1,Выборка.Количество);

КонецЦикла;


КонецПроцедуры
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
23.08.2011 09:33Ответ № 1
в запросе нужно указать отбор по номенклатуре и из текущей строки получить номенклатуру
Bell
23.08.2011 10:06Ответ № 2
СПАСИБО
Процедура СправочникСписокПриАктивизацииСтроки(Элемент)

СтрокаАктивная = ЭлементыФормы.СправочникСписок.ТекущиеДанные.Ссылка;
///Сообщить("СТРОКА "+Элементыформы.СправочникСписок.ТекущаяСтрока);

Запрос = Новый
Запрос("ВЫБРАТЬ

|ТМЦОстатки.ТМЦ КАК ТМЦ,
|ТМЦОстатки.МХ КАК МХ,
|ТМЦОстатки.КоличествоОстаток КАК Количество
|ИЗ
|РегистрНакопления.ОстаткиТМЦ.Остатки(&Дата,ТМЦ=&ТМЦ) КАК ТМЦОстатки");

Запрос.УстановитьПараметр("Дата",КонецДня(Дата) );
Запрос.УстановитьПараметр("ТМЦ",СтрокаАктивная );

Выборка = Запрос.Выполнить().Выбрать();

тпОстаткиМХ.Очистить();
Пока Выборка.Следующий() Цикл

НВС=тпОстаткиМХ.Добавить();// НВС=НоваяСтрока
НВС.Установить(0,Выборка.МХ);
НВС.Установить(1,Выборка.Количество);

КонецЦикла;


КонецПроцедуры
Подсказка: Для быстрого перемещения к последнему ответу или к вопросу используйте или .
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.