helpf.pro
Регистрация

v8.2 УП: Помогите с журналом

solnce721981
12.09.2011 14:00Прочитано: 1996
Помогите выделить проведенные документы в журнале ....либо цвет шрифта или цвет ячейки... и вообще это можно сделать?
Заранее спасибо
Yandex
Возможно, вас также заинтересует
Реклама на портале
Vedis70
12.09.2011 14:33Ответ № 1
Код 1C v 8.2 УП
 Процедура ЖурналДокументовСписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
Если ДанныеСтроки.Ссылка.Метаданные().Имя = "ПКО" Тогда
ОформлениеСтроки.ЦветФона = ЦветаСтиля.ЦветФонаПодсказки;
Иначе
ОформлениеСтроки.ЦветФона = ЦветаСтиля.ЦветФонаПоля;
КонецЕсли;
КонецПроцедуры
typeharley
13.09.2011 22:41Ответ № 2
А точнее:

Код 1C v 8.2 УП
 Если ДанныеСтроки.Проведен = Истина Тогда
ОформлениеСтроки.ЦветФона = ЦветаСтиля.ЦветФонаПодсказки;
Иначе
ОформлениеСтроки.ЦветФона = ЦветаСтиля.ЦветФонаПоля;
КонецЕсли;
solnce721981
14.09.2011 23:50Ответ № 3
(2) typeharley, спасибо-)
solnce721981
14.09.2011 23:50Ответ № 4
(1) Vedis70, спасибо за помощь
DJ_Serega
15.09.2011 09:43Ответ № 5
так закрывать нужно если все ок ;)
solnce721981
15.09.2011 23:25Ответ № 6
Вопрос закрыт!
Подсказка: Щелникни по Имени пользователя напротив ответа, и тем самым покажешь, что сообщение адресовано ему.
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.