helpf.pro
Регистрация

v8: Получить значение

Ermak
28.09.2011 13:04Прочитано: 1249
Добрый день! Сложилась не понятная ситуация. Существую колонки Количество, Цена, Сумма, СуммаТоваров, Расходы.

Количество и Цена пишу руками. Вот начинаю считать колонку СуммаТ

Код 1C v 8.2 УП
 Процедура ДанныеПоПартиямКоличествоПриИзменении(Элемент)
ДанныеСтроки = ЭлементыФормы.ДанныеПоПартиям.ТекущиеДанные;
ДанныеСтроки.СуммаТ = ДанныеСтроки.Цена * ДанныеСтроки.Количество;
КонецПроцедуры

Процедура ДанныеПоПартиямЦенаПриИзменении(Элемент)
ДанныеСтроки = ЭлементыФормы.ДанныеПоПартиям.ТекущиеДанные;
ДанныеСтроки.СуммаТ = ДанныеСтроки.Цена * ДанныеСтроки.Количество;
КонецПроцедуры


Все считает нормально.

Чтобы рассчитать Расход, нужно Сумма - СуммаТ
Вот пишут

Код 1C v 8.2 УП
 Процедура ДанныеПоПартиямСуммаПриИзменении(Элемент)
ДанныеСтроки = ЭлементыФормы.ДанныеПоПартиям.Данные;
ДанныеСтроки.Расходы = ДанныеСтроки.Сумма - ДанныеСтроки.СуммаТ
КонецПроцедуры

Процедура ДанныеПоПартиямСуммаТПриИзменении(Элемент)
ДанныеСтроки = ЭлементыФормы.ДанныеПоПартиям.Данные;
ДанныеСтроки.Расходы = ДанныеСтроки.Сумма - ДанныеСтроки.СуммаТ
КонецПроцедуры



И почему то не считает, почему?
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
28.09.2011 13:15Ответ № 1
а почему Расход не считаешь сразу, там же где и СуммаТ?
Ermak
28.09.2011 13:47Ответ № 2
(1) E_Migachev, Напишите как это будет выглядеть.
shcoder
28.09.2011 14:00Ответ № 3
А поставить точку отладки на строку:
Код 1C v 8.2 УП
 ДанныеСтроки.Расходы = ДанныеСтроки.Сумма - ДанныеСтроки.СуммаТ   

И посмотреть значения переменных пробовали? Очень похоже что просто не хватает данных, т.к. код вполне корректен.
Ermak
28.09.2011 14:47Ответ № 4
(3) shcoder, Работаю не давно в 1С 8 , отладкой еще не умею пользоваться. Каких данных может не хватать?
Ermak
28.09.2011 16:42Ответ № 5
Когда ищу значение Расходы, я использую событие ПриИзменении но я не чего не меняю в колонках СуммаТ и Сумма, там уже стоят значения, какое тогда можно использовать событие?
E_Migachev
28.09.2011 17:35Ответ № 6
Да сделай так:
Код 1C v 8.х
  Процедура ДанныеПоПартиямКоличествоПриИзменении(Элемент)
ДанныеСтроки = ЭлементыФормы.ДанныеПоПартиям.ТекущиеДанные;
ДанныеСтроки.СуммаТ = ДанныеСтроки.Цена * ДанныеСтроки.Количество;
ДанныеСтроки.Расходы = ДанныеСтроки.Сумма - ДанныеСтроки.СуммаТ;
КонецПроцедуры

Как только поменяют количество- сразу рассчитается СуммаТ и Расходы
Ermak
29.09.2011 08:55Ответ № 7
Все получилось Спасибо!!!!
Изменено 29.09.11 08:57:48
Ermak
29.09.2011 08:57Ответ № 8
Вопрос закрыт!
Подсказка: Вы можете добавить любую страничку в Избранное щелкнув по значку
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.