helpf.pro
Регистрация

v8: Обработка параметры

Bell
05.10.2011 12:59Прочитано: 1901
Здравствуйте
При провдении документа хочу выветси комментарий в таб. часть обработки.
Подскажите как передать параметры запроса на обоработку что бы заполнить ими таб. часть
КОММАЕНТАРИЙ сообщить
Код 1C v 8.х
 
Если (Выборка.Количество>Выборка.КоличествоОстаток)
И (Константы.флКонтрольОтрицательныхОстатков.Получить()=Истина) Тогда

Сообщить("Строка № "+Выборка.НомерСтроки+" нет "+Врег(Выборка.ТМЦ)+" "+Выборка.Партия+" "+
Выборка.Характеристика+" из необходимых "+
Выборка.Количество+" в наличии "+
Выборка.КоличествоОстаток+" отклонение "+
(Выборка.Количество-Выборка.КоличествоОстаток));
//----------------------------------------------------------------------------------------
ИзменениеТЧ = Обработки.КомментарийВыполненияДействий.Создать();
ФормаКомментарий=ИзменениеТЧ.ПолучитьФорму("КомментарийВыполненияДействий",ФормаДок,);

ФормаКомментарий.тхтДокумент = Ссылка);

// ФормаКомментарий.тблТМЦ.Добавить();


ФормаКомментарий.Открыть();

КонецЕсли;

Изменено 06.10.11 11:41:30
Yandex
Возможно, вас также заинтересует
Реклама на портале
typeharley
05.10.2011 13:56Ответ № 1
При открытии формы передай Владельца формы.
Bell
06.10.2011 11:49Ответ № 2
Я наверное чего то не понимаю параметры формы, я могу передать любые ,все у меня идет,а вот как передать параметры запроса (в таблицу обработки) которые получаются при провдении документа, ОбработкаПровдения()
При проведении документа ПЕРЕМЕЩЕНИЕ проверяются остатки на складе.
Если можно то по пунктам, что куда ставить или почитать про обработки как грамотно с ними работать (даннаые в них из доков , данные из них в доки и т.д) А то какие то обработки у меня получаются ,а какие то нет а по книгам (видио урокам) довольно тяжело там слишком все простое (примеры ) и хороших комментариев нет.
typeharley
06.10.2011 12:55Ответ № 3
Приведу пример показа статуса проведения документа. При проведении документа открывается общая форма и в нее передается статус проведения:

Код 1C v 8.2 УП
 Процедура ОбработкаПроведения(Отказ, РежимПроведения)
ФормаСтатуса = ПолучитьОбщуюФорму("ФормаСтатуса",,);
ФормаСтатуса.Заголовок = "Статус проводки";
ФормаСтатуса.ЭлементыФормы.Индикатор.Значение = 0;
ФормаСтатуса.Открыть();
i = 0;
Для Каждого СтрокаТовары Из ТаблТовары Цикл
i = i + 1;
ТекСтатус = ?(ТаблТовары.Количество() = 0, 0, 100*i/ТаблТовары.Количество());
ФормаСтатуса.ЭлементыФормы.Индикатор.Значение = ФормаСтатуса.ЭлементыФормы.Индикатор.Значение + ТекСтатус;
КонецЦикла;
КонецПроцедуры


Здесь ты меняешь элементы открытой формы. Можешь создать реквизит формы например типа "Структура" и установить значение через "ФормаСтатуса.СтруктураПараметров", затем в открытой форме обращаешься к нему как обычно!

Или наоборот, если не используется программная проводка (можно использовать форму самого документа): в модуле открывшейся формы можно обратиться к реквизитам формы владельца (формы, которая ее открыла):

Владелец = ЭтаФорма.ВладелецФормы.<Реквизит формы или переменная модуля>.

По большому счету можно передать контекст модуля в параметр открытой формы.
Да и еще есть большая куча способов передачи параметров в открывающуюся форму.
Изменено 06.10.11 12:57:13
Bell
07.10.2011 12:04Ответ № 4
Спасибо многое понял
Подсказка: Щелкнув по значку (справа от названия вопроса), вы получите список ответов на похожие вопросы!
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.