helpf.pro
Регистрация

v8: Обработка ОповеститьОВыборе

Bell
28.10.2011 14:57Прочитано: 5896
Здравствуйте

Решил попробовать сделать подбор через обработку, что не получается.

1. Открытие формы обработки кнопка подбор в Документе (Работает)

Код 1C v 8.х
 Процедура ПодборПартий(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка)
СтандартнаяОбработка = Ложь;
ВыбраннаяСтрока = ЭлементыФормы.тпПодбор.ТекущиеДанные.Ссылка;
БухгалтерскийУчет.ПодборПартий(ЭтаФорма,ВыбраннаяСтрока,МХоткуда,Дата);
КонецПроцедуры


2. Процедура общего модуля (Работает)


Код 1C v 8.х
 Процедура ПодборПартий(ЭтаФорма,ВыбраннаяСтрока,МХ,Дата) Экспорт

Перем Код,ТМЦ;
Перем СтруктураПараметров;

СтандартнаяОбработка = Ложь;

ТМЦ = ВыбраннаяСтрока.Наименование;
Код = ВыбраннаяСтрока.Код;

ФормаОбработки=Обработки.ПодборПартии.Создать();
ФормаВводПараметров = ФормаОбработки.ПолучитьФорму("ПодборПартии", ЭтаФорма);

ФормаВводПараметров.Заголовок = Врег(ТМЦ);
ФормаВводПараметров.тхтКод = Код;
ФормаВводПараметров.тхтТМЦ = ТМЦ;
//------------------------------------------------------------------------
//СтрокаПодбора = ЭлементыФормы.тпПодбор.ТекущиеДанные.Ссылка;

// ЗАПРОС (Сам Алгоритм) ……..

Запрос.УстановитьПараметр("Дата",КонецДня(Дата) );
Запрос.УстановитьПараметр("ТМЦ",ВыбраннаяСтрока );
Запрос.УстановитьПараметр("МХ",МХ );


Выборка = Запрос.Выполнить().Выбрать();
//------------------------------------------------------------------------
Пока Выборка.Следующий() Цикл

НВС=ФормаВводПараметров.Партии.Добавить();// НВС=НоваяСтрока
НВС.Контрагент = Выборка.Контрагент;
НВС.ТМЦ = Выборка.ТМЦ;
НВС.Партия = Выборка.Партия;
НВС.Характеристика = Выборка.Характеристика;
НВС.Цена1го = Выборка.Цена1гоОстаток;
НВС.Цена = Выборка.ЦенаОстаток;
НВС.Остаток = Выборка.КоличествоОстаток;

КонецЦикла;

СтруктураПараметров = ФормаВводПараметров.ОткрытьМодально();

КонецПроцедуры


2. Процедуры обработки (Вроде работает) параметры (ТМЦ,Количество) структуру параметров передается


Код 1C v 8.х
 Процедура ПартииВыбор(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка)  Экспорт

//Перем ТМЦ,Количество;
//Перем СтруктураПараметров;

СтандартнаяОбработка=Ложь;

Количество=1;
//
ТМЦ=ВыбраннаяСтрока.ТМЦ;

СтруктураПараметров = Новый Структура;
СтруктураПараметров.Вставить("ТМЦ", ТМЦ);
СтруктураПараметров.Вставить("Количество", Количество);
ОповеститьОВыборе(СтруктураПараметров);


КонецПроцедуры


ЭтаФорма.ЗакрыватьПриВыборе=Ложь;

3. Теперь я так понимаю надо оповестить о выборе форму документа (Не срабатывает)
.Что пропустил или сделал не правильно.
Код 1C v 8.х
 
Процедура тблТМЦОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)

Перем СтруктураПараметров;

НВС=тблТМЦ.Добавить();
//НВС.ТМЦ=СтруктураПараметров.ТМЦ;


КонецПроцедуры
Yandex
Возможно, вас также заинтересует
Реклама на портале
Bell
31.10.2011 19:31Ответ № 1
Все сделал
E_Migachev
01.11.2011 11:40Ответ № 2
(1) Bell, как сделал-то?
Подсказка: Для быстрого поиска ответов - используйте 'Поиск'
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.