helpf.pro
Регистрация

v8: Редактировать полные права

Ermak
15.11.2011 12:10Прочитано: 1240
Доброе утро!

У меня у пользователей ограничены права. После проведения документа, пользователь не может редактировать его. Как можно сделать, чтобы он редактировал в проведенном документе реквизиты которые я ему назначу?
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
15.11.2011 12:42Ответ № 1
(0) Ermak, проще всего программно прописать, то что можно редактировать
Ermak
15.11.2011 14:13Ответ № 2
Можно по подробнее, где?
И пример можно.
E_Migachev
15.11.2011 14:29Ответ № 3
например, закроем доступ всем у кого не доступна роль ТвояРольДоступа
Код 1C v 8.х
 Если НЕ РольДоступна("ТвояРольДоступа") Тогда
ЭлементыФормы.Код.Доступность=Ложь;
ЭлементыФормы.Наименование.Доступность=Ложь;
ЭлементыФормы.Комментарий.Доступность=Ложь;
// и т.д.
КонецЕсли;
Ermak
15.11.2011 14:40Ответ № 4
Я поставил код в процедуру ПриОткрытии() в модуль формы документы

Код 1C v 8.х
   Если НЕ РольДоступна("ПолныеПрава") Тогда
ЭлементыФормы.Товары.Колонки.СчетПоставщика.Доступность = Истина;

КонецЕсли;


и все равно когда захожу пользователем не с Полными правами он не дает редактировать реквизит СчетПоставщика
Почему?
Изменено 15.11.11 14:41:56
E_Migachev
15.11.2011 16:18Ответ № 5
там видимо срабатывает ТолькоПросмотр,
ппопробуй добавить в этот код
Код 1C v 8.х
 ТолькоПросмотр = Ложь;   

Изменено 15.11.11 16:20:54 по причине: Поправка
Ermak
15.11.2011 16:31Ответ № 6
(5) E_Migachev, поставил, но теперь пользователь может редактировать полностью документ, а нужно только колонку СчетПоставщика!
Появился еще вопрос, как он потом сохранит если у него нет прав на сохранения так как документ проведен?

Получается что так не возможно сделать как я хочу?
Изменено 15.11.11 16:34:22
E_Migachev
15.11.2011 16:53Ответ № 7
(6) Ermak, сделать возможно, но многое придется изменять:
- придется прописать для каждого поля доступность
- поправить проверки при записи документа
- поправить модуль проведения документа

так что - стоит ли оно того? решать тебе
Ermak
15.11.2011 17:51Ответ № 8
может и стоит )
Вы могли бы сказать где находятся эти модули
Изменено 15.11.11 17:52:09
E_Migachev
15.11.2011 18:11Ответ № 9
(8) Ermak, самое простое - запусаешь отладчик и смотришь куда и в какие модули он заходит
Ermak
15.11.2011 18:33Ответ № 10
Отладчиком не получается найти мало опыта. Ищу как работает кнопка Запись, в свойстве - действия стоит Записать, где находиться модуль, надо исправить чтобы она могла записывать когда если в правах ограничение на редактирование после проведения
Изменено 15.11.11 20:32:56
E_Migachev
16.11.2011 18:07Ответ № 11
(11) Ermak, так не получится, это запрещено на уровне платформы! тут нужно в правах все разрешить и программно уже запрещать что не нужно
Ermak
16.11.2011 18:12Ответ № 12
Хорошо!
Я доступ ограничу, но как написать, если документ проведен тогда разрешено только редактировать колонку 1
E_Migachev
17.11.2011 10:48Ответ № 13
(13) Ermak, в ПриОткрытии пишешь:
Код 1C v 8.х
 Если ЭтотОбъект.Проведен Тогда
ЭлементыФормы.Район.Доступность= Ложь;
ЭлементыФормы.Адрес.Доступность= Ложь;
// и также перечисляешь все другие реквизиты, которые хочешь закрыть
КонецЕсли;
Ermak
17.11.2011 10:59Ответ № 14
Спасибо попробую!
Ermak
17.11.2011 12:26Ответ № 15
Вопрос закрыт!
Подсказка: Для быстрого поиска ответов - используйте 'Поиск'
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.